Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows workstation that has established an SSH connection to a remote server using Putty. From that workstation, I can tunnel stuff through the SSH tunnel, including a HTTP proxy that is running on the SSH server

I'm wondering, is it possible to enable other computers in the same subnet as the workstation to connection to that workstation, and use its SSH tunnel/HTTP proxy?

I tried using the "Local ports accept connections from other hosts" option in Putty, but I still get a connection refused when I try to connect from other boxes to the Windows workstations.

What is the proper way to configure this, so that I can share the HTTP proxy via SSH tunnel?

Cheers, Victor

share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted

This is dependend which settings you used for the tunnels.

Forget the crap which I wrote. Go with settings like these but point the destination to the proxy server like you already did before I told you otherwise.

tunnel settings

After initiating the tunnel use netstat -a and look if the port is openend correctly under the address 0.0.0.0.

$ netstat -a | find "3025"
  TCP    0.0.0.0:3025           pacey-PC:0            ABHÖREN
  TCP    [::]:3025              pacey-PC:0            ABHÖREN

You can also check the eventlog in the putty menu.

share|improve this answer
    
That's actually what I've set - "Local ports accept connections from other hosts" is set to on, source port is set to 22, destination is set to "x.x.x.x:22" (my LAN IP). When I try to netcat on port 22 to this box from another box, I get "port 22 (tcp) failed: Connection refused". –  victorhooi Nov 12 '10 at 7:14
1  
Might be a firewall issue. Depending on which version of windows you are on you might have an active Windows Firewall. –  pacey Nov 12 '10 at 7:17
    
Ok, I seem to be through when I set it to source port 22, destination set to "hostname.com:22". However, using destination "localhost:22" doesn't seem to work. Any idea why that is, or the difference between them? I thought localhost in that context was the SSH server? Also, Komodo IDE, using Open Remote Files to SSH server localhost (via the Putty tunnel) works if it's set to localhost, but not hostname (i.e. the opposite). Kinda annoying, I have to swap back/forth...any idea why? –  victorhooi Nov 15 '10 at 3:21
    
Can you set this via the command line? I run it like this putty.exe -ssh -v -i key.ppk -D 9853 admin@example.com –  Allan Kimmer Jensen Aug 14 '13 at 10:29
add comment

[corrected based on below comment]

telnet to the forwarded port from local machine and then from remote machine. If you are able to connect using local machine (where putty is running) and not from other machine then it is firewall issue or SSH client is listening only on local port and not on 0.0.0.0 for incoming connections.

share|improve this answer
    
SSH clients typically have a flag that specifies whether other machines on the network are allowed to connect to the forwarded port. So even without firewalling this may not work. –  Sean Reifschneider Nov 14 '10 at 21:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.