Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On several Windows 2008 Server machines I'll log onto, when expanding folders in Windows Explorer with the treeview on the left, at times, it can take forever for the nodes to expand. Oftentimes there'll be some type of animation icon. I'll also usually see a BG progress meter in the address bar at the top of Windows Explorer, indicating it's looking or searching thru files. The folders I'm expanding will sometimes have little or no files in them. So I'm clueless what Explorer is taking so much time for. With other versions of Windows, even when there are many files in the sub-folders, expanding the nodes is basically instantaneous.

When this happens, I can usually start double-clicking on the folders on the right side listview to drill down very quickly. I've seen this with both Server 2008 RTM and R2 -- both seem to have this problem.

This is very frustrating overall dealing with a slow OS. Any ideas or tips on something I can do? Thanks.

share|improve this question

migrated from Nov 12 '10 at 7:12

This question came from our site for computer enthusiasts and power users.

This question should be posted on the ServerFault website. There are many smart IT professionals over there. – MHrappstead Nov 12 '10 at 3:29
Thanks, before posting, I looked at to see the differences between the sites. Based on the short description, both SuperUser and ServerFault seemed applicable. I picked one. Seems like the 2 sites could be combined! If I don't get a response here, I'll post there. Thanks. – Ben Amada Nov 12 '10 at 3:53
I posted this question on ServerFault --… – Ben Amada Nov 12 '10 at 7:01
I'm awarding the answer to Robert Kerr (not because it was an A/V problem), but because he tipped me off to use Process Explorer to find the problem. See my comments under Robert's answer to see what the problem was. – Ben Amada Nov 24 '10 at 20:42
up vote 0 down vote accepted

In my experience this is quite often an active virus scanner aggressively rescanning files in the subfolders of the folder you are expanding. (Editorial: I find this behavior extremely annoying to myself and to all of my customers) Run some type of process monitor (procmon from SysInternals comes to mind immediately) and open one of those difficult folders. Then stop capture on procmon and examine what is happening.

share|improve this answer
I downloaded Process Monitor and I may have identified the problem. This machine (and others I connect to) I connect to via Remote Desktop. I'm mapping my local drive to. The folders that are slow to expand are local folders (not on my machine). But before I'm expanding the local folders, I've already opened up my mapped drive to copy some files to the local machine (local = the machine I'm connected to). Even though I'm no longer doing anything with my mapped drive, Process Monitor is showing constant Explorer.EXE operations such as QueryBasicInformationFile, CloseFile, etc (cont) – Ben Amada Nov 19 '10 at 3:08
(cont) for files on my mapped drive. The files are mostly ZIP files that it looks like Explorer.EXE is interrogating. So it seems that Explorer.EXE is tied up going thru all these ZIP files on my machine while I'm trying to expand folders on the local machine (the machine I'm connected to). Maybe there's a setting to turn off Explorer from going thru ZIP files (on my machine or the local machine). I'll see how it goes for the next couple of days. After I found this, I disconnected, turned off mapped folders, reconnected and expanding folders is fast. (cont) – Ben Amada Nov 19 '10 at 3:11
(cont) hopefully, it will remain fast with the mapped drives off. I'll look for an option to tell explorer to not interrogate ZIP files. It could be non-ZIP files too that are slowing it down, and just enumerating files on a mapped drive is the main culprit ... but the ZIP ones were what I saw most (or maybe entirely). I'll post back here in a couple of days. Thx. – Ben Amada Nov 19 '10 at 3:13
Everything is fast now. I have mapped drives turned on again, but I make sure that the ZIP files are not in the mapped folder I'm accessing (I moved them out of there). Explorer no longer wastes resources looking thru the ZIP files on my computer. I'm guessing it was even more wasteful since it would probably need to download the ZIPs to the remote computer (from my computer) to open the ZIPs. Happy to have this solved. I do think though that it's a poor design by MS, and they could improve this by avoiding costly and unnecessary interrogation of these ZIP files. – Ben Amada Nov 24 '10 at 20:45

If the directory listings via the command prompt is "acceptable" (without delay), then it may be Windows Explorer building thumbnails for the files.

share|improve this answer
I haven't made any changes, but a couple of server 2008 machines are expanding folders much faster now (that happens sometimes). I'm waiting for them to become slow again. The two settings I see offhand for thumbnails in Windows Explorer are (1) Always show icons, never thumbnails, and (2) Display file icon on thumbnails. If the problem is thumbnails as you suggest, I should set these to Yes and No respectively? – Ben Amada Nov 13 '10 at 23:54
It's REALLY slow now (slowest ever). Using the command prompt, I can list the directory contents w/ no issues -- it's lightening fast. I've tried changing those 2 settings I mentioned, but it has only seemed to get worse. I closed Windows Explorer, and when I reopen it, the only 2 icons in the treeview are Favorites and Library. Both of them have animated magnifying glass icons, indicating that Windows Explorer is looking thru the folders and doing something. If anyone can provide specific tips on what settings to change, that would be very helpful. – Ben Amada Nov 16 '10 at 20:22
You might look into "dumbing down" your graphics effects settings, since the command prompt performance is a pretty good indication that it is likely a graphics driver/hardware issue/limitation. – user48838 Nov 17 '10 at 8:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.