Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to setup email forwarding through fetchmail from remote smtp server to Gmail account, although messages are constantly coming to my local address and accessible via "mail" command. SMTP connection works perfectly, but emails do not go anywhere.

System: debian, fetchmail Config: poll smtp.server protocol imap username “user” password “pass” smtpname “user@gmail.com” ssl

Thank you!

share|improve this question

closed as off-topic by Jenny D, dawud, TheCleaner, Falcon Momot, Katherine Villyard Mar 31 at 22:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Jenny D, dawud, TheCleaner, Falcon Momot, Katherine Villyard
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

have a look at the manual, it's recommend's to use --smtphost <server>

source: man fetchmail

Did not test it but I guess it should look like something like the below:

poll imap.domain.com with protocol IMAP
user 'username' password 'password' smtpname 'username@gmail.com' smtphost 'smtp.gmail.com'

share|improve this answer
    
Yes, I've tried that, but server replies that STARTTLS should have been issued... –  0100110010101 Nov 12 '10 at 16:35
    
What if you download and install the certificate? Then specify the following as a new line: "options ssl sslcertpath /etc/ssl/certs" –  Mark Nov 13 '10 at 17:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.