Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been experiencing a problem with my virtual hosts, I don't understand why apache looks for /home/* directory if my virtualhosts' directory is somewhere else?

tail -f /var/log/apache2/error.log

/home/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

Sultan

share|improve this question

4 Answers 4

up vote 0 down vote accepted

It shouldnt..

You must have this somewhere in your apache configs..

Or you have a softlink somewhere in your webdirectory/code to your home account..

share|improve this answer
    
Actually my virtualhosts are stored in my /home/www/hostsdirectory does it affect somehow? –  sultan Nov 12 '10 at 16:01
    
Well it seems that your webroot is then considered as /home/* as you said.. Apache by default looks in "every" directory for a .htaccess file.. You should probably look at you base document root in your httpd.conf file.. Also do you have any idea which vhosts is requesting your /home/.htaccess?? –  Arenstar Nov 12 '10 at 16:04
    
I've about 10 virtual hosts and requests on allof them give the same result –  sultan Nov 12 '10 at 16:06
    
Very strange.. Make sure your vhosts are having the document root set properly /home/www/website.com/ And check your code.. your might be referencing.. ../../../../image.jpeg or /home/www/website.com/../../image.jpeg –  Arenstar Nov 12 '10 at 16:17
    
For sure I'd say this happens even if I setup some example.com with some "hello world" message within index file –  sultan Nov 12 '10 at 16:42

755 ist the answer, as all your files have to be readable by railo (which is actually not the same user as your Apache).

share|improve this answer

Permissions on /home may not allow apache to read the directory appropriately.

The document root for the websites should be under /var/www or /srv/www. This allows you to have tight security on the home directory tree.

Specify the full DocumentRoot for your virtual servers.

Check that you haven't enabled user directories for your virtual servers. These will walk the /home tree.

share|improve this answer
    
The reason I keep all of my Virtual hosts at my home directory /home/sultan/Web/... –  sultan Nov 13 '10 at 11:51

Try to chmod 755 /home/www then do the same with "hostdirectory"

chmod 755 /home/www/hostdirestory
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.