Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install SVN on a CentOS virtual machine.

I used the command that the CentOS wiki tells: http://wiki.centos.org/HowTos/Subversion

yum install mod_dav_svn subversion

It gives me a few errors:

--> Finished Dependency Resolution
mod_dav_svn-1.4.2-4.el5_3.1.i386 from base has depsolving problems
  --> Missing Dependency: httpd-mmn = 20051115 is needed by package mod_dav_svn-1.4.2-4.el5_3.1.i386 (base)
subversion-1.4.2-4.el5_3.1.i386 from base has depsolving problems
  --> Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386 (base)
Error: Missing Dependency: perl(URI) >= 1.17 is needed by package subversion-1.4.2-4.el5_3.1.i386 (base)
Error: Missing Dependency: httpd-mmn = 20051115 is needed by package mod_dav_svn-1.4.2-4.el5_3.1.i386 (base)

The thing is that I have Perl 5.8 installed:

root@server [~]# rpm -q perl perl-5.8.8-32.el5_5.2

I also don't know why it tells httpd-mmn isn't installed. I have apache installed for sure. From what I read here, it seems I would need to recompile apache.

www.sitepoint.com /forums/showthread.php?t=485683

Any ideas?

Update: I also tried to install subversion via WHM (11.28.35) and it gives me the same error. By the way, WHM it says: CENTOS 5.5 i686 virtuozzo on server

share|improve this question

5 Answers 5

Regarding perl(URI), this sometimes happens with perl modules, where the name embedded in the package which needs a thing is not quite the same as the name of the package that provides the thing. In this case a yum list |grep URI tells me that the package is called perl-URI, and is currently in the main repositories for CentOS at 1.35-3, which should do you.

Do a

yum install perl-URI

Regarding httpd-mmn, I'm confused. I have a number of stock CentOS boxes, and when I do a yum install mod_dav_svn subversion it tells me that it needs only httpd (and moreover, it picks up the right perl-URI automatically). As Ignacio says above, is it possible that you're running a system which isn't using the stock httpd and perl packages from CentOS, but another provider's? Can you do an

rpm -qi httpd perl

and post the results?

share|improve this answer

It's telling you that version 1.17 of Perl's URI module is unavailable (yum whatprovides 'perl(URI)').

As for httpd-mmn, that is provided by the httpd package; perhaps the one you have installed is the wrong version (rpm -q --whatprovides httpd-mmn).

If you have some sort of control panel such as CPanel installed then it would install its own httpd and Perl, meaning that you wouldn't be able to get at the packages in the base repo. Talk to your panel vendor if this is the case.

share|improve this answer
    
This is what I get: root@server [~]# yum whatprovides 'perl(URI)' Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * addons: centos.intergenia.de * base: centos.intergenia.de * extras: centos.intergenia.de * updates: centos.intergenia.de Excluding Packages in global exclude list Finished Warning: 3.0.x versions of yum would erroneously match against filenames. You can use "*/perl(URI)" and/or "*bin/perl(URI)" to get that behaviour No Matches found –  Emerson Nov 13 '10 at 19:26
    
Then no package that is not excluded in your repos has it. See the last bit I wrote in my answer. –  Ignacio Vazquez-Abrams Nov 13 '10 at 19:57

Ok, either your using a non standard repo, or messed up your package manager by installing a rpm yourself... try this..

Cpan install URI

I think You have installed your own rpm for perl??? Therefor you need to install everything your self, basically when you step out from the managed repo for core modules (like perl) you are going to have some problems with dependancies.

Hand roll your subversion, its really easy. Or go back to repository standard modules :)

im sure there is some hacks to get it to work (which i wouldnt apply on my server)

Hope this helps :)

share|improve this answer
    
it gives me: No package perl-URI.noarch available. Nothing to do –  Emerson Nov 13 '10 at 19:23
    
Wow... ummm take off the .noarch.. do a.. yum update.. yum upgrade.. yum perl-uri.. What version of centos is it? –  Arenstar Nov 13 '10 at 19:29
    
WHM says: CENTOS 5.5 i686 virtuozzo on server –  Emerson Nov 13 '10 at 19:37
    
yum install perl-URI gives "No package perl-URI available. Nothing to do" –  Emerson Nov 13 '10 at 19:38
    
It seems something isnt standard here.. Your apache doesnt support modules, your havent the standard perl packages.. Check your repo.. It all seems strange to me.. –  Arenstar Nov 13 '10 at 19:45

You can get an RPM for Perl's URI module from the official CentOS mirror. If you're using CentOS 5 then the following command should solve your problem:

rpm -ivh http://mirror.centos.org/centos-5/5/os/i386/CentOS/perl-URI-1.35-3.noarch.rpm
share|improve this answer

for the uri my solution was found here: http://sdkit.com/tutorial/how-to-fix-missing-dependency-perluri-1-17-is-needed-by-package-subversion/

using centos 5.8, 3 commands needed:

wget http://sdkit.com/download/centos/5/rpms/perl-URI-1.35-3.noarch.rpm

rpm -i perl-URI-1.35-3.noarch.rpm

yum install subversion

According to following link http-mnm is installed along with apache > 2.x but its in the yum excludes and you have to comment it out: http://stackoverflow.com/questions/610115/centos-install-mod-dav-svn

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.