Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a windows 7 box stashed away in my closet, containing (among other things) 2 big HDDs linked together as a mirrored volume - basically a super lazy NAS / media server. I've noticed that when that drive is accessed (whether locally, on the machine itself, or remotely, from another computer, or my xbox, for example) there's a noticeable pause, and then from the computer itself, a 'click!' noise, after which the drive is accessed; e.g. open \\computername\shared\, wait 2 seconds, hear 'click!' and then see files appear in windows explorer.

Any ideas? Otherwise the drive preforms normally - is it a windows thing? a HDD-about-to-die thing? Or a "yeah that always happens, you've just never noticed it before" thing?

share|improve this question

3 Answers 3

up vote 6 down vote accepted

Sounds like power management is allowing the disks to spin down due to inactivity. Whether or not that's going to impact the long-term reliability of the disks is something that's been debated in the community. (Personally I'd rather have the disks spinning 24 x 7 so that they're at a constant temperature but that's purely a personal opinion.)

share|improve this answer
    
You know, I wondered if it was something like that - if that's the case, is it reasonable to assume that it's happening specifically because I'm setting up the mirror through windows' disk management, instead of doing an actual hardware raid1? –  matt lohkamp Nov 14 '10 at 2:54
    
@Matt, no, it's the power settings in the control panel. Edit the current power profile and turn off power savings for the hard disks. –  Chris S Nov 14 '10 at 3:05
    
Oh yeah, I didn't think of that - for some reason I always forget that it's not just laptops that have those options. I'll try that out today, and see if it makes a difference... I suspect that it will. –  matt lohkamp Nov 15 '10 at 1:47
    
yep, you're right - I tried changing the hard drive timeout to like 5 minutes, and then it was happening all the time, same thing. Definitely just the power saver mode. Thanks! –  matt lohkamp Nov 15 '10 at 5:09

If you hear more clicks in a short period of time than you have drives (so if there's just two drives, more than two clicks within a minute or so), it's probably a drive (or more than one) going bad. Check out the SMART data (system log may show errors, or try a program that reports SMART data) for problems.

If it's not this, it's almost certainly what Evan proposed.

share|improve this answer

In my experience, a click is the first sign, then there is random clicks.... Followed by some grinds.... Ending in no noise :(

Check your drives with a tool such as hdparm

The answer regarding spindown is quite correct depending though on, how long the disks need to be saving power/rotations. My home server had 16 hours a day of non use (it was worth the spin down)

Hope this helps :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.