Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

ServerFault,

After some really great trouble-shooting sessions with help from some people on Experts-Exchange... I've managed to get my 2621xm connected to BroadVoice's SIP Service through Call Manager Express (v3.1).

It works great!

But there's always a hitch. As soon as I did it, and was able to place calls using the BroadVoice service, I lost the ability to dial my Unified Messaging mailboxes on an internal server.

Right now, I have the dial-peer "5000" and "5001" pointing to my internal exchange server, When I dial both numbers in those peers (*99) or (1111), I get "unknown number" on the 7960s and the fast-busy signal which means it's probably something wrong with my dial-peer.

It looks as if the problem started when I adjusted my MWI indicator to the BroadVoice service, instead of my Exchange 2007 box.

Any assistance in restoring my mailbox services would be greatly appreciated. I've posted my scrubbed config below:

!  
! Last configuration change at 06:39:05 JST Fri Nov 12 2010 by *****  
! NVRAM config last updated at 06:39:08 JST Fri Nov 12 2010 by *****  
!  
version 12.4  
service timestamps debug datetime msec  
service timestamps log datetime msec  
service password-encryption  
!  
hostname *****A  
!  
boot-start-marker  
boot system flash:c2600-adventerprisek9-mz.124-15.T7.bin  
boot-end-marker  
!  
enable secret *****  
!  
aaa new-model  
!  
!  
aaa group server radius *****  
 server 10.0.226.251 auth-port 1645 acct-port 1646  
 server 10.0.226.252 auth-port 1645 acct-port 1646  
!  
aaa group server radius *****  
 server 10.0.2.251 auth-port 1645 acct-port 1646  
 server 10.0.2.252 auth-port 1645 acct-port 1646  
!  
aaa group server radius *****  
 server 10.0.12.251 auth-port 1645 acct-port 1646  
 server 10.0.12.252 auth-port 1645 acct-port 1646  
!  
aaa authentication login *****_Access group ***** local  
aaa authorization network default if-authenticated   
!  
!  
aaa session-id common  
clock timezone *****  
ip cef  
!  
!  
!  
!  
ip domain name *****.com  
ip host sip.broadvoice.com 147.135.20.221  
ip host lax.broadvoice.com 147.135.8.128  
ip host dca.broadvoice.com 147.135.0.128  
ip host mia.broadvoice.com 147.135.4.128  
ip host atl.broadvoice.com 147.135.28.128  
ip host chi.broadvoice.com 147.135.12.221  
ip host bos.broadvoice.com 147.135.32.221  
ip host nyc.broadvoice.com 147.135.20.221  
ip name-server *****  
ip name-server *****  
ip multicast-routing   
ip inspect max-incomplete low 500  
ip inspect max-incomplete high 700  
ip inspect one-minute low 400  
ip inspect one-minute high 400  
ip inspect udp idle-time 120  
ip inspect dns-timeout 3  
ip inspect tcp idle-time 360  
ip inspect tcp synwait-time 15  
ip inspect name *****_FW tcp  
ip inspect name *****_FW udp  
ip inspect name *****_FW icmp  
ip inspect name *****_FW ftp  
!  
multilink bundle-name authenticated  
!  
!  
!  
voice rtp send-recv  
!  
voice service voip   
 allow-connections h323 to h323  
 allow-connections h323 to sip  
 allow-connections sip to h323  
 allow-connections sip to sip  
 redirect ip2ip  
 h323  
 sip  
  bind control source-interface Dialer1  
  bind media source-interface Dialer1  
  registrar server expires max 3600 min 3600  
!  
!  
voice class codec 1  
 codec preference 1 g711ulaw  
 codec preference 2 g711alaw  
 codec preference 3 g729r8  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
!  
voice source-group *****_InboundSIP  
 access-list 1  
!  
voice translation-rule 1  
 rule 1 /.+/ /*****/  
!  
voice translation-rule 2  
 rule 1 /^99\(.......\)$/ /1208\1/  
 rule 2 /^99\(..........\)$/ /1\1/  
 rule 3 /^99\(.*\)/ /\1/  
 rule 4 /*****/ /5999/  
!  
voice translation-rule 3  
 rule 1 /*****/ /5999/  
!  
!  
voice translation-profile BroadVoice  
 translate calling 1  
 translate called 2  
!  
voice translation-profile BroadVoice_800  
 translate called 3  
!  
!  
!  
application  
  service CME_AA flash://its-CISCO.2.0.1.0.tcl  
  param operator 1999  
  paramspace english language en  
  paramspace english index 0  
  paramspace english location flash://  
  paramspace english prefix en  
  param aa-pilot 5999  
  !  
!  
!  
!  
!  
!  
username ***** privilege 15 secret *****  
username ***** privilege 15 secret *****  
archive  
 log config  
  hidekeys  
!   
!  
crypto isakmp policy 1  
 encr aes 256  
 hash md5  
 authentication pre-share  
 group 2  
crypto isakmp key ***** address *****  
crypto isakmp keepalive 10  
!  
!  
crypto ipsec transform-set ESP-AES esp-aes 256   
!  
crypto map *****_VPNMap 1 ipsec-isakmp   
 description *****A VPN --> *****A VPN  
 set peer *****  
 set security-association lifetime seconds 86400  
 set transform-set ESP-AES   
 set pfs group2  
 match address *****_VPNTraffic  
!  
!  
!  
!  
class-map match-any P2P  
 match protocol edonkey  
 match protocol gnutella  
 match protocol kazaa2  
 match protocol winmx  
class-map match-all VoiceOverIPSignaling  
 match ip dscp af31   
class-map match-all VoiceOverIP  
 match ip dscp ef   
 match protocol sip  
 match protocol skinny  
!  
!  
policy-map VoiceOverIPPolicy  
 class VoiceOverIP  
  priority percent 10  
 class VoiceOverIPSignaling  
  bandwidth percent 2  
 class class-default  
  fair-queue  
policy-map Drop_P2P  
 class P2P  
   drop  
!  
!  
!  
!  
!  
interface Loopback1  
 ip address 172.16.0.1 255.255.255.255  
 ip ospf 1 area 0  
!  
interface Tunnel1  
 ip address 172.16.0.209 255.255.255.252  
 ip nat inside  
 ip virtual-reassembly  
 ip ospf authentication message-digest  
 ip ospf message-digest-key 1 md5 *****  
 ip ospf mtu-ignore  
 ip ospf 1 area 0  
 keepalive 5 3  
 tunnel source Dialer1  
 tunnel destination *****  
 crypto map *****_VPNMap  
!  
interface FastEthernet0/0  
 description *****A Fa0/0 --> *****C Fa0/3 (10.0.0.0/23)  
 ip address 10.0.0.1 255.255.254.0  
 ip nbar protocol-discovery  
 ip nat inside  
 ip virtual-reassembly  
 ip ospf authentication message-digest  
 ip ospf message-digest-key 1 md5 *****  
 speed 100  
 full-duplex  
 service-policy input Drop_P2P  
!  
interface FastEthernet0/1  
 description *****A Fa0/1 --> ***** ISP Equipment  
 no ip address  
 no ip redirects  
 no ip unreachables  
 no ip proxy-arp  
 ip virtual-reassembly  
 no ip mroute-cache  
 speed 100  
 half-duplex  
 pppoe enable group global  
 pppoe-client dial-pool-number 1  
!  
interface Dialer1  
 description *****A Dialer1 --> ***** WAN (ISP)  
 mtu 1424  
 bandwidth 100000  
 ip address negotiated  
 no ip unreachables  
 ip nbar protocol-discovery  
 ip nat outside  
 ip inspect *****_FW out  
 ip virtual-reassembly  
 encapsulation ppp  
 ip tcp adjust-mss 1396  
 no ip mroute-cache  
 dialer pool 1  
 dialer-group 1  
 no cdp enable  
 ppp authentication chap pap callin  
 ppp chap hostname *****  
 ppp chap password *****  
 ppp pap sent-username ***** password *****  
 ppp ipcp route default  
 crypto map *****_VPNMap  
 service-policy output VoiceOverIPPolicy  
!  
router ospf 1  
 router-id 10.0.0.1  
 log-adjacency-changes  
 area 0 authentication message-digest  
 summary-address 10.0.0.0 255.255.240.0  
 summary-address 10.0.224.0 255.255.240.0  
 redistribute static subnets  
 passive-interface default  
 no passive-interface FastEthernet0/0  
 no passive-interface Tunnel1  
 network 10.0.0.0 0.0.15.255 area 0  
 network 172.16.0.209 0.0.0.0 area 0  
 default-information originate  
!  
ip forward-protocol nd  
ip route 0.0.0.0 0.0.0.0 Dialer1  
!  
!  
ip http server  
no ip http secure-server  
ip http path flash:  
ip dns server  
ip nat inside source list *****_NAT interface Dialer1 overload  
ip nat inside source static tcp 10.0.0.6 25 interface Dialer1 25  
ip nat inside source static tcp 10.0.210.221 8420 interface Dialer1 8420  
ip nat inside source static tcp 10.0.210.221 8419 interface Dialer1 8419  
ip nat inside source static tcp 10.0.210.221 8418 interface Dialer1 8418  
ip nat inside source static tcp 10.0.210.221 8417 interface Dialer1 8417  
ip nat inside source static tcp 10.0.210.221 8416 interface Dialer1 8416  
ip nat inside source static tcp 10.0.210.221 8415 interface Dialer1 8415  
ip nat inside source static tcp 10.0.210.221 8414 interface Dialer1 8414  
ip nat inside source static tcp 10.0.210.221 8413 interface Dialer1 8413  
ip nat inside source static tcp 10.0.210.221 8412 interface Dialer1 8412  
ip nat inside source static tcp 10.0.210.221 8411 interface Dialer1 8411  
ip nat inside source static tcp 10.0.2.221 443 interface Dialer1 443  
ip nat inside source static tcp 10.0.210.221 5356 interface Dialer1 5356  
ip nat inside source static tcp 10.0.210.221 8410 interface Dialer1 8410  
ip nat inside source static tcp 10.0.210.221 8409 interface Dialer1 8409  
ip nat inside source static tcp 10.0.210.221 8408 interface Dialer1 8408  
ip nat inside source static tcp 10.0.210.221 8407 interface Dialer1 8407  
ip nat inside source static tcp 10.0.210.221 8406 interface Dialer1 8406  
ip nat inside source static tcp 10.0.210.221 8405 interface Dialer1 8405  
ip nat inside source static tcp 10.0.210.221 8404 interface Dialer1 8404  
ip nat inside source static tcp 10.0.210.221 8403 interface Dialer1 8403  
ip nat inside source static tcp 10.0.210.221 8402 interface Dialer1 8402  
ip nat inside source static tcp 10.0.210.221 8401 interface Dialer1 8401  
ip nat inside source static tcp 10.0.210.221 8400 interface Dialer1 8400  
ip nat inside source static tcp 10.0.210.221 8453 interface Dialer1 8453  
ip nat inside source static tcp 10.0.210.221 8443 interface Dialer1 8443  
ip nat inside source static udp 10.0.2.221 8081 interface Dialer1 8081  
ip nat inside source static tcp 10.0.2.221 8081 interface Dialer1 8081  
ip nat inside source static udp 10.0.2.221 21 interface Dialer1 21  
ip nat inside source static tcp 10.0.2.221 21 interface Dialer1 21  
ip nat inside source static tcp 10.0.2.221 20 interface Dialer1 20  
ip nat inside source static udp 10.0.2.221 20 interface Dialer1 20  
ip nat inside source static tcp 10.0.2.221 80 interface Dialer1 80  
ip nat inside source static tcp 10.0.2.221 110 interface Dialer1 110  
ip nat inside source static tcp 10.0.2.221 143 interface Dialer1 143  
!  
ip access-list extended *****_NAT  
 deny   ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255  
 deny   ip 10.0.0.0 0.0.255.255 172.16.0.0 0.0.255.255  
 deny   ip 172.16.0.0 0.0.255.255 10.0.0.0 0.0.255.255  
 deny   ip 172.16.0.0 0.0.255.255 172.16.0.0 0.0.255.255  
 permit ip 10.0.0.0 0.0.255.255 any  
 permit ip 172.16.0.0 0.0.255.255 any  
ip access-list extended *****_SplitTunnel  
 permit ip 10.0.0.0 0.0.15.255 10.0.12.0 0.0.1.255  
 permit ip 10.0.224.0 0.0.15.255 10.0.12.0 0.0.1.255  
ip access-list extended *****_VPNTraffic  
 permit ip 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255  
 permit icmp 10.0.0.0 0.0.255.255 10.0.0.0 0.0.255.255  
 permit gre host ***** host *****  
!  
access-list 1 permit 147.135.28.128  
access-list 1 permit 147.135.4.128  
access-list 1 permit 147.135.0.128  
access-list 1 permit 147.135.8.128  
access-list 1 permit 147.135.12.221  
access-list 1 permit 147.135.20.221  
access-list 1 permit 147.135.32.221  
access-list 1 permit 10.0.0.0 0.255.255.255  
access-list 1 permit 172.16.0.0 0.0.255.255  
access-list 1 deny   any log  
snmp-server community public RO  
!  
!  
!  
!  
tftp-server flash:P00307020200.bin alias P00307020200.bin  
tftp-server flash:P00307020200.loads alias P00307020200.loads  
tftp-server flash:P00307020200.sb2 alias P00307020200.sb2  
tftp-server flash:P00307020200.sbn alias P00307020200.sbn  
tftp-server flash:Analog1.raw alias Analog1.raw  
tftp-server flash:Analog2.raw alias Analog2.raw  
tftp-server flash:AreYouThere.raw alias AreYouThere.raw  
tftp-server flash:AreYouThereF.raw alias AreYouThereF.raw  
tftp-server flash:Bass.raw alias Bass.raw  
tftp-server flash:CallBack.raw alias CallBack.raw  
tftp-server flash:Chime.raw alias Chime.raw  
tftp-server flash:Classic1.raw alias Classic1.raw  
tftp-server flash:Classic2.raw alias Classic2.raw  
tftp-server flash:ClockShop.raw alias ClockShop.raw  
tftp-server flash:DistinctiveRingList.xml alias DistinctiveRingList.xml  
tftp-server flash:Drums1.raw alias Drums1.raw  
tftp-server flash:Drums2.raw alias Drums2.raw  
tftp-server flash:FilmScore.raw alias FilmScore.raw  
tftp-server flash:HarpSynth.raw alias HarpSynth.raw  
tftp-server flash:Jamaica.raw alias Jamaica.raw  
tftp-server flash:KotoEffect.raw alias KotoEffect.raw  
tftp-server flash:MusicBox.raw alias MusicBox.raw  
tftp-server flash:Piano1.raw alias Piano1.raw  
tftp-server flash:Piano2.raw alias Piano2.raw  
tftp-server flash:Pop.raw alias Pop.raw  
tftp-server flash:Pulse1.raw alias Pulse1.raw  
tftp-server flash:Ring1.raw alias Ring1.raw  
tftp-server flash:Ring2.raw alias Ring2.raw  
tftp-server flash:Ring3.raw alias Ring3.raw  
tftp-server flash:Ring4.raw alias Ring4.raw  
tftp-server flash:Ring5.raw alias Ring5.raw  
tftp-server flash:Ring6.raw alias Ring6.raw  
tftp-server flash:Ring7.raw alias Ring7.raw  
tftp-server flash:RingList.xml alias RingList.xml  
tftp-server flash:Sax1.raw alias Sax1.raw  
tftp-server flash:Sax2.raw alias Sax2.raw  
tftp-server flash:Vibe.raw alias Vibe.raw  
tftp-server flash:cmterm_7920.4.0-02-00.bin alias cmterm_7920.4.0-02-00.bin  
radius-server host 10.0.12.251 auth-port 1645 acct-port 1646 key *****  
radius-server host 10.0.12.252 auth-port 1645 acct-port 1646 key *****  
radius-server host 10.0.228.251 auth-port 1645 acct-port 1646 key *****  
radius-server host 10.0.228.252 auth-port 1645 acct-port 1646 key *****  
radius-server host 10.0.2.251 auth-port 1645 acct-port 1646 key 7 *****  
radius-server host 10.0.2.252 auth-port 1645 acct-port 1646 key 7 *****  
!  
control-plane  
!  
!  
!  
voice-port 1/0/0  
!  
voice-port 1/0/1  
!  
voice-port 1/1/0  
 supervisory disconnect dualtone mid-call  
 pre-dial-delay 0  
 cptone JP  
 timeouts call-disconnect 1  
 timeouts ringing 45  
 timeouts wait-release 2  
 connection plar 5999  
!  
voice-port 1/1/1  
!  
ccm-manager music-on-hold  
!  
mgcp  
mgcp bind control source-interface FastEthernet0/0  
mgcp bind media source-interface FastEthernet0/0  
mgcp behavior g729-variants static-pt  
!  
!  
!  
dial-peer voice 1 voip  
 destination-pattern 1...  
 voice-class codec 1  
 session target ipv4:10.0.0.1  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
!  
dial-peer voice 2 voip  
 destination-pattern 2...  
 voice-class codec 1  
 session target ipv4:10.0.208.1  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
!  
dial-peer voice 99 pots  
 destination-pattern 0T  
 port 1/1/0  
 forward-digits all  
!  
dial-peer voice 5999 voip  
 service cme_aa  
 destination-pattern 5999  
 voice-class codec 1  
 session target ipv4:172.16.0.1  
 incoming called-number 5999  
 dtmf-relay h245-alphanumeric  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
 no vad  
!  
dial-peer voice 5000 voip  
 description *****A --> ***** UM  
 destination-pattern 5000  
 voice-class codec 1  
 session protocol sipv2  
 session target ipv4:10.0.2.241  
 session transport tcp  
 dtmf-relay rtp-nte  
 fax rate disable  
 fax protocol pass-through g711ulaw  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
 no vad  
!  
dial-peer voice 100 voip  
 description *****A --> BroadVoice SIP  
 translation-profile outgoing BroadVoice  
 destination-pattern 99T  
 voice-class codec 1  
 session protocol sipv2  
 session target sip-server  
 dtmf-relay rtp-nte  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
 no vad  
!  
dial-peer voice ***** voip  
 description BroadVoice SIP --> *****A (Inbound Calls)  
 translation-profile incoming BroadVoice  
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte  
 session protocol sipv2  
 session target sip-server  
 incoming called-number *****  
 dtmf-relay rtp-nte  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
 no vad  
!  
dial-peer voice 800 voip  
 description BroadVoice SIP (800) --> *****A (Inbound Calls)  
 translation-profile incoming BroadVoice_800  
 voice-class codec 1  
 voice-class sip dtmf-relay force rtp-nte  
 session protocol sipv2  
 session target sip-server  
 incoming called-number *****  
 dtmf-relay rtp-nte  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
 no vad  
!  
dial-peer voice 5001 voip  
 description *****A --> ***** UM (Operator)  
 destination-pattern 5001  
 voice-class codec 1  
 session protocol sipv2  
 session target ipv4:10.0.2.241  
 session transport tcp  
 dtmf-relay rtp-nte  
 fax rate disable  
 fax protocol pass-through g711ulaw  
 ip qos dscp cs5 media  
 ip qos dscp cs4 signaling  
 no vad  
!  
!  
sip-ua   
 credentials username ***** password ***** realm BroadWorks  
 authentication username ***** password ***** realm BroadWorks  
 calling-info pstn-to-sip from number set *****  
 no remote-party-id  
 retry invite 4  
 retry response 3  
 retry bye 2  
 retry cancel 2  
 retry register 3  
 timers register 250  
 mwi-server dns:sip.broadvoice.com expires 3600 port 5060 transport udp unsolicited  
 registrar dns:sip.broadvoice.com expires 3600  
 sip-server dns:sip.broadvoice.com  
  host-registrar  
!  
!  
!  
telephony-service  
 load 7960-7940 P00307020200  
 load 7920 cmterm_7920.4.0-02-00  
 max-ephones 24  
 max-dn 48  
 ip source-address 10.0.0.1 port 2000  
 service phone displayIdleTimeout 00:30  
 service phone displayOnDuration 1:00  
 timeouts interdigit 2  
 system message *****.com  
 url services http://phone-xml.berbee.com/menu.xml  
 time-zone 44  
 time-format 24  
 voicemail 5000  
 max-conferences 4 gain -6  
 call-forward pattern ....  
 moh music-on-hold.au  
 web admin system name admin secret *****  
 dn-webedit   
 transfer-system full-consult  
 transfer-pattern ....  
 secondary-dialtone 99  
 after-hours block pattern 1 0041 7-24  
 after-hours block pattern 2 010 7-24  
 after-hours block pattern 3 011 7-24  
 after-hours block pattern 4 0990 7-24  
 after-hours block pattern 5 1900 7-24  
 after-hours block pattern 6 99010 7-24  
 after-hours block pattern 7 99011 7-24  
 after-hours block pattern 8 991900 7-24  
 directory entry 2 ***** name ***** Cell  
 directory entry 1 ***** name ***** Cell  
 directory entry 3 ***** name ***** Cell  
 create cnf-files version-stamp 7960 Sep 24 2010 18:03:15  
!  
!  
ephone-template  1  
 softkeys idle  Redial Newcall Pickup Cfwdall Dnd  
 softkeys seized  Redial Endcall Cfwdall Pickup Gpickup  
 softkeys alerting  Endcall Callback  
 softkeys connected  Hold Confrn Flash Park Trnsfer  
!  
!  
ephone-dn  1  dual-line  
 call-waiting ring  
 number 1009 no-reg primary  
 pickup-group 1  
 label *****  
 description *****A  
 name *****  
 call-forward busy 5000  
 call-forward noan 5000 timeout 18  
!  
!  
ephone-dn  2  dual-line  
 call-waiting ring  
 number 1001 no-reg primary  
 pickup-group 1  
 label ***** *****  
 description *****B  
 name *****  
 call-forward busy 5000  
 call-forward noan 5000 timeout 18  
!  
!  
ephone-dn  3  dual-line  
 call-waiting ring  
 number 2001 no-reg primary  
 pickup-group 2  
 label ***** *****  
 description *****A  
 name *****  
 call-forward busy 5000  
 call-forward noan 5000 timeout 18  
!  
!  
ephone-dn  4  dual-line  
 call-waiting ring  
 number 1002 no-reg primary  
 pickup-group 1  
 label ***** *****  
 description *****B  
 name *****  
 call-forward busy 5000  
 call-forward noan 5000 timeout 18  
!  
!  
ephone-dn  5  dual-line  
 call-waiting ring  
 number 2002 no-reg primary  
 pickup-group 2  
 label ***** *****  
 description *****A  
 name *****  
 call-forward busy 5000  
 call-forward noan 5000 timeout 18  
!  
!  
ephone-dn  9  
 number 9999 no-reg primary  
 paging ip 239.1.1.100 port 2000  
!  
!  
ephone-dn  10  
 number 1999 no-reg primary  
 call-forward busy 5000  
 call-forward noan 5000 timeout 18  
!  
!  
ephone-dn  11  
 number 2999 no-reg primary  
!  
!  
ephone-dn  40  
 number 5001 no-reg primary  
 park-slot timeout 90 limit 3  
!  
!  
ephone-dn  41  
 number 5002 no-reg primary  
 park-slot timeout 90 limit 3  
!  
!  
ephone-dn  42  
 number 5003 no-reg primary  
 park-slot timeout 90 limit 3  
!  
!  
ephone-dn  47  
 number A2 no-reg primary  
 intercom A1 barge-in no-mute label "*****"  
!  
!  
ephone-dn  48  
 number A1 no-reg primary  
 intercom A2 barge-in no-mute label "*****"  
!  
!  
ephone  1  
 device-security-mode none  
 description *****A  
 mac-address *****  
 ephone-template 1  
 paging-dn 9  
 type 7960  
 keep-conference  
 button  1o1,10 6:47  
!  
!  
!  
ephone  2  
 device-security-mode none  
 description *****B  
 mac-address *****  
 ephone-template 1  
 paging-dn 9  
 type 7960  
 keep-conference  
 button  1o2,10  
!  
!  
!  
ephone  3  
 device-security-mode none  
 description *****A  
 mac-address *****  
 ephone-template 1  
 paging-dn 9  
 type 7960  
 keep-conference  
 button  1o3,11  
!  
!  
!  
ephone  4  
 device-security-mode none  
 description *****C  
 mac-address *****  
 ephone-template 1  
 paging-dn 9  
 type 7960  
 button  1o4,10 6:48  
!  
!  
!  
ephone  5  
 device-security-mode none  
 description *****A  
 mac-address *****  
 ephone-template 1  
 paging-dn 9  
 type 7920  
 button  1o4,10  
!  
!  
!  
ephone  6  
 device-security-mode none  
 description *****A  
 mac-address *****  
 ephone-template 1  
 type 7920  
 button  1o5,11  
!  
!  
banner motd   
*************************************************************  
************  Unauthorized Access is Prohibited  ************  
*************************************************************  

  Access to this system is for the use of authorized  
  personel only.  

  You are hereby advised that all actions performed are  
  subject to monitoring and are being recorded.  In the  
  event of any possible criminal activity, evidence will  
  be turned over to proper Law Enforcement personnel,  
  and offenders will be prosecuted!  

  You have accessed:  $(hostname).$(domain)  

*************************************************************  
************  Unauthorized Access is Prohibited  ************  
*************************************************************  

!  
line con 0  
 privilege level 15  
 logging synchronous  
 login authentication *****_Access  
line aux 0  
 logging synchronous  
 login authentication *****_Access  
line vty 0 4  
 logging synchronous  
 login authentication *****_Access  
line vty 5 181  
 logging synchronous  
 login authentication *****_Access  
!  
ntp clock-period 17180425  
ntp master  
ntp server *****  
!  
end  
share|improve this question

1 Answer 1

Any assistance at all would be very much appreciated.

I think I've isolated the problem, but I have absolutely no idea on how to fix it.

I've included a fresh copy of my UM dial-peers down below, as well as a nice scrubbed debug here:

I think the problem is that my incoming number to the UM box is being reported as the one assigned to me by BroadVoice, and not the 4 digit extension that's calling.

If that is the problem, how do I change it - to not use that - and just use the 4 digit extension as it's calling number?


debug ccsip calls

Dec 1 15:14:49.511: //24/8E92D873807E/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x84696424

State of The Call : STATE_DEAD

TCP Sockets Used : YES

Calling Number : ##########

Called Number : 5000

Source IP Address (Sig ): 10.0.12.1

Destn SIP Req Addr:Port : 10.0.2.241:5060

Destn SIP Resp Addr:Port : 10.0.2.241:5060

Destination Name : 10.0.2.241

USSOK2611A#

Dec 1 15:14:49.515: //24/8E92D873807E/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream : 1

Negotiated Codec : No Codec

Negotiated Codec Bytes : 0

Negotiated Dtmf-relay : 0

Dtmf-relay Payload : 0

Source IP Address (Media): 10.0.12.1

Source IP Port (Media): 17114

Destn IP Address (Media): 0.0.0.0

Destn IP Port (Media): 0

Orig Destn IP Address:Port (Media): 0.0.0.0:0

Dec 1 15:14:49.515: //24/8E92D873807E/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC) : 38

Disconnect Cause (SIP) : 200


dial-peer voice 5000 voip

description USSOK2621A --> USSOKEX1 UM (Mailbox)

destination-pattern 5000

voice-class codec 1

session protocol sipv2

session target ipv4:10.0.2.241

session transport tcp

dtmf-relay rtp-nte

fax rate disable

fax protocol pass-through g711ulaw

no vad

! dial-peer voice 5001 voip

description USSOK2621A --> USSOKEX1 UM (Operator)

destination-pattern 5001

voice-class codec 1

session protocol sipv2

session target ipv4:10.0.2.241

session transport tcp

dtmf-relay rtp-nte

fax rate disable

fax protocol pass-through g711ulaw

no vad

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.