Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to upload (transfer) a 35GB file to a linux server through SFTP (filezilla). After about 15 hours and 8% progress, I got an error on filezilla saying "Connection timed out".

How can I change or disable the ftp timeout?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

@3mb's a minute.. wow ( this is going to take some time ) :P

170hours or so... hehe

What is your ftp daemon on the server???

I would attempt to edit these things on your daemon..

http://www.proftpd.org/docs/directives/linked/config_ref_TimeoutSession.html http://www.proftpd.org/docs/directives/linked/config_ref_TimeoutNoTransfer.html

And this on your ftp client (Filezilla)

http://forum.hostek.com/showthread.php?230-How-to-disable-FTP-timeout-in-Filezilla

share|improve this answer
    
yeah, its going to take about a week A: proftpd, if you're referring to the ftp server –  arcov5 Nov 15 '10 at 7:38
    
Updated my answer :D –  Arenstar Nov 15 '10 at 7:48
add comment

Time-outs might indicate the transfer will never complete if your disable timeouts.

Since, so far as I know, FTP and SFTP can't resume an upload, I would do the FTP as a get from the other end, and use resume when the connection times-out.

Since time does not seem to be an issue, if you have the disk space you could use split to break the data into smaller chunks, with greater chance of success with the transfer of each chunk.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.