Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am currently on a Xeon 7550 server running Redhat x86_64 es5 with 32gb RAM. I have memcache installed and the only step remaining in the configuration is to set how much memory it uses. I had done this on my old server, where I downloaded a file on through Filezilla (root access) and edited it. Now, I cant remember which file I edited and exactly how the process went. I want to set the memery to use 1 GB.

Anyone with some insight? Please be thorough if you will assist, as my linux server knowledge is limited.

share|improve this question
    
Also, what was the command that I run to view the current memcache settings...? –  Peter Johansson Nov 15 '10 at 15:10
add comment

3 Answers

I use Ubuntu, and Debian mostly, so this answer is based on those, but I suspect the answer for other distros is largely the same.

In /etc/memcached.conf -- If it's not in exactly the same place, a) I'd be surprised, and b) you could find it with locate

# Start with a cap of 64 megs of memory. It's reasonable, and the daemon default
# Note that the daemon will grow to this size, but does not start out holding this much
# memory
-m 64

So all you need do, is change the -m 64 line to

-m 4096

Or similarly large value in Megabytes.

There's some other yummy tuning parameters in there, such as the user it runs as, and what to do when it runs out of memory, and the IP address to bind the daemon to.. Have a look for yourself.

share|improve this answer
    
This doesnt work for RedHat however –  Arenstar Nov 15 '10 at 15:30
add comment

Settings are maintained here..

   /etc/sysconfig/memcached

Change

# set ram size to 2048 - 2GiB

    CACHESIZE="4096"

Type the following command:

memcached-tool IP_ADDRESS:Port
memcached-tool 127.0.0.1:11211 display
memcached-tool 127.0.0.1:11211 stats
share|improve this answer
    
Im not to sure if this is correct, I typed the memcached-tool and it gave me: "# Item_Size Max_age Pages Count Full? Evicted Evict_Time OOM" –  Peter Johansson Nov 15 '10 at 15:19
    
oooooooooooops.. my mistake..... i linked you to the stats tool.. let me fix that.. use "stats" memcached tool –  Arenstar Nov 15 '10 at 15:25
    
As far as viewing the stats is concerned, I tend to just telnet localhost 11211, but that's because I can't guarantee the installation or portability of memcached-tool, but nc or telnet are often available. –  Tom O'Connor Nov 15 '10 at 15:28
    
Your totally right, fortunately in RH and Centos, its packaged together.. –  Arenstar Nov 15 '10 at 15:29
    
Did this work??? –  Arenstar Nov 17 '10 at 15:45
show 1 more comment

For some distro it's location at /etc/init.d/ with the file name memcached

   /etc/init.d/

Change

# set ram size to 8MBytes to 256MBytes

    MEMSIZE=256
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.