Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The external network interface (eth0) on one of our servers is periodically freezing up. It also has a local network interface (eth1), so I'm able to connect to the server through one of the other servers in the same network. Any connections through the external network - such as SSH from my local machine, ping from my local machine, SSH from a dev server on a different network - all time out. While connecting through one of the other servers in its local network, I can run sudo ifdown eth0 && sudo ifup eth0 and the interface magically works again. If I try the ifup command first instead of bringing the interface down, it gives me an error message saying the interface is already up.

As a workaround, I've tried adding the following line to my root crontab:

55 1 * * * ifdown eth0 && ifup eth0 &> /dev/null

Confusingly, that doesn't actually resolve the issue. A backup job that runs 5 minutes later is unable to copy the files to a machine outside the local network.

You can see the output of sudo dmesg here.

The server is an HP ProLiant DL360 G5 running Ubuntu Lucid (10.04). Thank you in advance for any help on how to track this issue down and resolve it!

share|improve this question
    
Please can you post the output of the command dmesg? –  fahadsadah Nov 15 '10 at 15:56
    
Second that.. lets see some dmesg –  Arenstar Nov 15 '10 at 16:08
    
I added a link to the dmesg output above. Thanks! –  Brandon Konkle Nov 15 '10 at 16:32
    
Looking at the bottom of the output, there's definitely some relevant info. I'm not sure how to interpret it, though. –  Brandon Konkle Nov 15 '10 at 16:34

1 Answer 1

1- You can monitor the traffic on this interface using the command:

sudo tcpdump -i eth0 -s 1518 -XX -vv -n -w /tmp/trace_file.pcap

Try to connect and see if the interface receives any traffic.

2- Check if you can access other machines FROM this server other than to this server using eth0.

3- Check the interface status using: ethtool eth0.

4- Check the interface status using the sys files under /sys/class/net/eth0/*

5- Check your firewall status (active or inactive) and check the rules if any.

6- Check the kernel debug messages using dmesg and check the system log file /var/log/messages for any errors/warnings.

Hope this will help!

share|improve this answer
    
This is definitely helpful - I wasn't sure how to diagnose the issue and you've given me a lot of guidance. Thanks! As for #2 on the list, I can (as expected) access other servers on the local network from the offending server, but nothing externally. –  Brandon Konkle Nov 15 '10 at 16:36
    
@Brandon: If you can post any suspicious output, I may able to help your further. Or hopefully someone else can do :) –  Khaled Nov 16 '10 at 8:10
    
Okay, it happened again this morning. Attempts to SSH to the server from outside the local network result in ssh: connect to host myserver port 22: Operation timed out. For #1 above, I ran the command for about a minute, and it said 15 packets received by filter, 0 packets dropped by kernel. Running a second time for 2 minutes returned 0 packets for both. For #3, I got this output. I'm not sure which files to look for in the directory from #4. For #5, there are no rules restricting traffic. For #6, I got this output about eth0. –  Brandon Konkle Nov 16 '10 at 15:36
    
@Brandon: I suggest that you use the default network driver (kernel module) that comes with Linux which is tg3 instead of the one you are using now! –  Khaled Nov 17 '10 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.