Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a 5TB raid 5 virtual disk cluster... I think the MBR got messed up and windows server 2003 no longer is able to view the contents of the virtual disk...

All the disk recovery software I have tried will fail due to the large amount of files we have, about 64 million files.

Some raid software will save the recovered files to another disk.. however 5TB is a large amount of data to save and we do not have any disks or other virtual disks that large.

The disks are not critical enough to send away and have a professional recovery company get the data back... just wondering if I have any other options to try and ether fix the MBR or somehow scan and get the data back... its in a NTFS file format.

any suggestions or advise would be wonderful, thanks!


share|improve this question
What 'disk recovery software' have you tried, may as well let us know before we recommend the same ones to you? presumably you can't just restore from backup? –  Chopper3 Nov 15 '10 at 16:29
If the files are worth >$1000 to you, which presumably they are, and you have time I would buy a few 2TB consumer level SATA drives, then use a disk imager (or linux dd) and image each drive individually to the backup drives. Be sure to label/mark them with the exact order they were in in your original array! That way you can "rollback" if your repair efforts only cause more damage. –  bot403 Nov 15 '10 at 16:44
unfortunately a portion of data did not get backed up, we had been unaware of this backup problem prier to the failure of the raid group... –  Stephen Nov 15 '10 at 16:44
We have tried: *Getdataback (new and old versions, and contacted their support they cannot support anything over a few million files) *Active@ File Recovery *Recuva *DiskInternals *TestDisk –  Stephen Nov 15 '10 at 16:49
5tb is 2 end user discs in a raid 0 - stable enough to try a recover there, then move from there to a new disc. Seriously. it is not that much. Not 2013. Not if the data has any value. –  TomTom Dec 8 '13 at 9:51

2 Answers 2

When you say a virtual disk setup - do you mean this array was created in Windows?

If not, I've seen something similar with some Dell PowerEdge servers where you muck around with some of the disks in the array and it then appears as corrupt to the OS. In this case you need to boot into the RAID manager from the boot screens and set the array as active (I think import foreign array sometimes does the trick).

Just a thought

share|improve this answer
Thanks Georage thats great information, i will try that... –  Stephen Nov 15 '10 at 20:12
Thanks Georage thats great information, i will try that... Its a Dell Perc 6/i that controls the raid... not windows... windows just wants to format the drive... I will try and log into the controller... –  Stephen Nov 15 '10 at 20:21

Have you tried using the FIXMBR command using a Windows 2003 Server disk?

  1. Boot with server installation disk.
  2. Select the recovery console
  3. Select the partition

You could also try Active Partition Recovery: http://www.partition-recovery.com/

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.