Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am getting the error in the title when trying to connect to my MySQL server. I have reinstalled MySQL and PHP several times and tried a slew of command line work based on information I searched out.

web.mysql is running and I know that my mysql.sock exists and is located in ~/private/tmp/ and also in ~/tmp/. I also have plenty of hard drive space. I have installed and setup phpMyAdmin correctly only adding a password to 'Password for config auth'. I have also connected to the server via Sequel Pro.

Why can't I connect to the server via phpMyAdmin? I'm on a 64-bit Intel Mac running Snow Leopard

share|improve this question

Make sure phpMyAdmin is not trying to look for mysql.sock in /var/lib/mysql/. I had the same error yesterday and creating a link from /var/lib/mysql/mysql.sock to /tmp/mysql.sock fixed it.

share|improve this answer

Sometimes MySQL sets itself to only accept incoming on the loopback address ( PHPMyAdmin is most likely trying to connect to "localhost".

You can change the my.cnf file to allow all connections to the MySQL server or modify the PHPMyAdmin config to point to My suggestion would be to do the later in case of future upgrades.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.