Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having an issue kickstarting an installation of VMWaare ESX Classic 4.1. I've stripped down my kickstart a bit to just:

accepteula

keyboard us

auth

clearpart --firstdisk --overwritevmfs

url --url=10.16.0.1/cblr/ks_mirror/esx-classic-4.1.0-260247

rootpw --iscrypted $1$zZJa3g7g$mD8d.6QgbPku1QovQTAps/

timezone 'US/Pacific'

network --addvmportgroup=true --device=vmnic0 --bootproto=dhcp

part '/boot'  --fstype=ext3 --size=1100  --onfirstdisk
part 'none'  --fstype=vmkcore --size=110  --onfirstdisk
part 'datastore1'  --fstype=vmfs3 --size=8920 --grow  --onfirstdisk

virtualdisk 'esxconsole' --size=7920 --onvmfs='datastore1'

part 'swap'  --fstype=swap --size=916 --onvirtualdisk='esxconsole'
part '/var/log'  --fstype=ext3 --size=2000 --onvirtualdisk='esxconsole'
part '/'  --fstype=ext3 --size=5000 --grow --onvirtualdisk='esxconsole'

%post --interpreter=bash

However, when I attempt to use this kickstart during a PXE install with no additional kernel options, I get the following error:

There was a problem with the Network Device specified on the command line.
Error: No NIC found with name bootif

If I comment out the network line in the kickstart, the error changes to:

There was a problem with the Network Device specified on the command line.
Error: No NIC found with name eth0

How can I fix this? Thanks.

share|improve this question
    
Why are you bothering, do you really need the SC? –  Chopper3 Nov 16 '10 at 21:29
    
Sorry, I'm not familiar with that abbreviation SC –  William Nov 16 '10 at 21:38
    
Service Console. It's the primary difference between ESX and ESXi –  Mark Henderson Nov 17 '10 at 20:35

3 Answers 3

up vote 1 down vote accepted

You might try adding "IPAPPEND 2" to your pxe stanza.

Also, are you sure that the drivers for your nic exist in the installer you are trying to boot?

share|improve this answer

Did you try setting --device=eth0 in the network line? I looked at this:

and that's the only mention of and always eth0.

EDIT: Since OP uses Cobbler, this is the important link:

share|improve this answer
    
I'll give it a shot, thanks. I recall trying this and having something go wrong. –  William Nov 16 '10 at 21:11
    
Well I tried that but the first error persisted, No NIC found with name bootif. –  William Nov 16 '10 at 21:17
    
Do you have ksdevice parameter to kernel defined in your PXE config? Look here: blog.scottlowe.org/2010/03/02/pxe-booting-vmware-esx-40 –  icyrock.com Nov 16 '10 at 21:21
    
I've tried with it both defined (as vmnic0 and eth0) and not defined. Unfortunately the error is still there. –  William Nov 16 '10 at 21:35
    
That's a bummer - do you have any mention of bootif anywhere in your config files or is this some VMWare default? –  icyrock.com Nov 16 '10 at 21:38

The error comes from the installer trying to parse the kernel boot command line BOOTIF=XXX parameter. Check the boot command line with cat /proc/cmdline to see what you booted with. BOOTIF it typically added by a PXE bootloader, but can also be found in grub.conf

Edit:

This can also happen if 'ksdevice=' or 'netdevice=' are set on the kernel cmdline

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.