Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi I have a Win 2K3 with 6 gigs of memory.

I had 3 gigs, and then added 3 more.

However Windows won't recognize more than 4 Gigs as its a 32 bits machine.

What do I have to do to make things work?

I've two sql instances and set SQL Maximum memory for them both as 2560, and clicked Enable AWE checkbox.

Is this enough? I've heard it's actually not, windows should recognize the memory first. How do I do that? Is Min Memory required to be more than 0 for AWE to work?

Thanks in advance. Gabriel Guimarães

share|improve this question
1  
Why are you running 32-bit W2K3? –  Sim Nov 16 '10 at 21:28
    
Some 3rd party vendors haven't signed off on 64-bit yet. I know, I know. But it happened to us for an ERP package we were using for HR. –  K. Brian Kelley Nov 16 '10 at 21:36
    
@K Brian Kelley - Understood, we have faced that battle as well. Often the vendors, especially sales reps or account execs, confuse the front-end client with the back-end database in terms of support and just give a blanket not supported, so persisting in asking about the database and any associated middleware can pay off. –  Sim Nov 16 '10 at 21:46
    
Yup, always good to check it all the way through. We did. It was the server installation that wasn't supported for our case. –  K. Brian Kelley Nov 16 '10 at 21:49
    
@Sim I'm running x86 W2K3 because it was not my choice, rs. –  Gabriel Guimarães Nov 17 '10 at 11:53

2 Answers 2

up vote 4 down vote accepted

If you are running on Enterprise or Datacenter Edition for the operation system, you need to do a few other things. If you are running Windows Server 2003 Standard, you cannot use more than 4 GB of memory, as mentioned by Sim. Here's what you need to do if you're on Enterprise or Datacenter Edition:

  1. The /PAE switch must be set in boot.ini: Books Online: Using AWE.
  2. Lock Pages in Memory must be set for the SQL Server service account: Books Online: How to: Enable the Lock Pages in Memory Option (Windows).
  3. Awe Enabled must be configured and the SQL Server restarted: Books Online: Enabling AWE Memory for SQL Server.
share|improve this answer
    
Hi Brian, Damn... I'm running Standard Edition. Thanks Anyway. –  Gabriel Guimarães Nov 17 '10 at 11:55

If the server is Windows 2003 Standard Edition then it only supports 4GB maximum of physical memory - see MSDN - Memory Limits for Windows Releases. Best option is to go 64-bit Windows and SQL.

For more info on AWE and SQL see Enabling AWE Memory for SQL Server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.