Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Cisco SPA942 phone, which is no longer supported by Cisco. It's running the latest firmware available for this phone: 6.1.5(a). Cisco replaced the SPA942 with the SPA504G, which is almost identical to the SPA942 hardware-wise. I noticed that the SPA504G has a newer firmware available (7.4.6) that adds some features that I'd like to have (a call ignore soft button and G.722 HD support).

I tried downloading and executing the 7.4.6 firmware upgrade tool, and going through the screens it didn't tell me I couldn't apply this SPA504G update to the SPA942. I stopped short of clicking the Upgrade button on the final screen before the upgrade, as I wasn't sure if this upgrade would brick the phone.

Is it safe to apply this SPA504G update to the SPA942?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Not quite sure if it'll brick your phone but I can almost guarantee you that you're probably breaking the license agreement for the 7.4.6 firmware. Don't put your company at risk, follow the licensing requirements. If you can't do that with your current hardware, then upgrade your hardware.

share|improve this answer
    
Good point. I'm not interested in doing it if it'll result in a license violation. –  Alex Nov 16 '10 at 23:41
add comment

Maybe you can do the upgrade, but you should not. I bet that the upgrade program will not even let you to upgrade the different hardware.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.