Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is my homework/assignment. I have done until a certain step and got stuck. I'm facing the same issue as this person that I've googled online: http://ubuntuforums.org/showthread.php?t=621901

I'm supposed to work with UW-IMAPD package. The instructions in my assignment is as follows:

  1. Download the IMAPD source code from the subject website.
  2. Expand the source code and tarball it contains.
  3. Compile the source code by reading the instructions in the expanded object (consult README). To compile you will need to use the HOST Target known as LNP (Linux PAM Support). You will also need to ensure that in the Makefile SSL support is set to the value none.
  4. Install the ipop3d binary produced after the compile into the directory /usr/local/bin
  5. Create a user account for yourself. Give it a password.
  6. Make sure the POP3 service is started when a user connects to it. To do this you will need to invoke the ipop3d daemon. This is done by adding a new service to xinetd.
  7. Add appropriate PAM authentication support for POP and IMAP. This is done by adding the appropriate files in /etc/pam.d (you need to add pop and imap files). You should use pam_unix.so as the library for login, account and session in PAM. Once done you will need to reboot the virtual machine. PAM is the Plugable Authentication Module framework which allows programs to use a variety of directory services etc for authentication.
  8. Send the user you created a mail, using the mail command.
  9. Demonstrate the POP3 server works, by telnetting to its port on localhost and issuing commands i.e. login and access a message. You will need to research the protocol here.
  10. Configure the mutt mail client to read mail from the POP3 server on the localhost. Again show it works. To do this you will need to edit the file .muttrc in the users home directory and use the directives set pop_host and exec fetch-mail. To run mutt, simply run mutt at the prompt. Further information can be obtained by reading the muttrc man page.

For each step, record the commands you use and any output if any (including screenshots). You are to get POP working (only POP3). You are to submit a report showing how you got this working – it should encompass all commands used.

I have downloaded IMAPD source, unzip the contents and tried compiling it using the following code:

make lnp SSLTYPE=none

I got some error in the result, but I still managed to see ipopd folder with ipop2d.c and ipop3d.c in it.

The error looks like:

make[3]: *** [onceenv] Error 1
make[3]: Leaving directory `/tmp/imap-2006e/c-client'
make[2]: *** [lnp] Error 2
make[2]: Leaving directory `/tmp/imap-2006e/c-client'
make[1]: *** [OSTYPE] Error 2
make[1]: Leaving directory `/tmp/imap-2006e'
make: *** [lnp] Error 2

So I tried to install ipop3d binary to /usr/local/bin by typing:

install /tmp/imap-2006e/ipopd/ipop3d.c /usr/local/bin

The file gets transferred over. I suppose it's installed?

After this step, I don't know how to continue. Previously, I tried compiling ipop3d.c, and it gave me lots of errors.

Any advice would be appreciated. Thank you.

Regards, Wallace

share|improve this question

migrated from stackoverflow.com Nov 17 '10 at 0:55

This question came from our site for professional and enthusiast programmers.

1  
You're not posting enough of the error. –  Mark Wagner Nov 17 '10 at 5:40

1 Answer 1

If imapd source tarball contains 'configure' script then you should run configure and give it host type 'LNP' and disable SSL support. Then you should run make.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.