Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Windows Server 2008 machine running in VirtualBox. On initial installation, only one processor was made available, but now I want to run it as a multiprocessor machine.

I have made all four cores available in the VirtualBox settings (as well as enabling VT-x/AMD-V and Nested Paging), but Task Manager still only shows one CPU. However, the four CPU cores are visible in Device Manager under Processors.

In the event log on startup, I can see the following relevant events:

EventLog.6009 Microsoft (R) Windows (R) 6.00.6002 Service Pack 2 Multiprocessor Free
Kernel-Processor-Power.4 Processor 0 exposes the following: 1 idle state(s), 0 performance state(s), 0 throttle state(s)
Kernel-Processor-Power.4 Processor 255 exposes the following: 0 idle state(s), 0 performance state(s), 0 throttle state(s)
Kernel-Processor-Power.4 Processor 255 exposes the following: 0 idle state(s), 0 performance state(s), 0 throttle state(s)
Kernel-Processor-Power.4 Processor 255 exposes the following: 0 idle state(s), 0 performance state(s), 0 throttle state(s)

How can I make this system actually boot up as a multiprocessor machine?

share|improve this question
I know that in XP you need to switch the HAL and the kernel to multiprocessor versions, but all I've read indicates that in 2008 that's the default, and the startup log seems to indicate this. –  David Fraser Nov 17 '10 at 9:06
I also tried manually overriding numproc in the boot configuration, to no avail –  David Fraser Nov 17 '10 at 9:06
I have a XP VM that successfully boots in multiprocessor mode on the same host; I've compared the configuration XML and there are no differences on the CPU features etc –  David Fraser Nov 17 '10 at 13:27
Hold on a second, did you add cores or did you add processors? –  SpacemanSpiff Apr 24 '12 at 21:15
@SpacemanSpiff - what do you mean? In VirtualBox, it has a System/Processors tab with a slider to select the number of processors; since these are virtual there's no distinction there between cores or processors. –  David Fraser Apr 25 '12 at 14:07

3 Answers 3

This is a common issue in the worl of PtoV, VtoP etc, but I always forget the resolutions that have worked for me.

One that springs to mind is deleting the ACPI device from Device Manager

But here is something thats looks similar to your issue, given that your event log shows all cpus.


Browse to c:\windows\system32
Right click on HAL.DLL
Click the version tab
Click Internal Name.  Here it will tell you definitly which HAL you are running.

You want halmacpi, not halaacpi

share|improve this answer

It could be that your processor does not support VT-x , if so then 1 core will only be possible.

Have a look at this thread to get the gist http://superuser.com/questions/33723/getting-2-processors-to-work-with-virtualbox-on-dual-core-celeron

share|improve this answer
Good idea, but it does support VT-x - I've run a Windows XP virtual machine on here with 4 cores successfully. (Plus that question shows that On the acceleration tab, 'Enable VT-x/AMD-v' was grayed out, whereas mine is enabled). –  David Fraser Nov 17 '10 at 12:49

Ok David, just re-read your Question and I think the problem may lie in the fact that I dont think you can add extra cores to the OS post install (unlike memory). I've never had to do this but it makes sense. To test, why dont you try and install a quick Win OS with the correct settings and see at the end that they have/ havent been picked up...

share|improve this answer
+1 here - this requires another HAl to bei nstalled, and this is choosen at install time. –  TomTom Nov 17 '10 at 16:25
I may indeed try that. But the documentation does say that Windows Server 2008 only has a multiprocessor HAL and kernel - and I've checked the dll names etc –  David Fraser Nov 18 '10 at 10:46
Think you are missing the point David. I am saying that your initial install occurred when you had "one core". You cannot simply add more cores and expect them to appear in Windows. You will need to re-install to pick up the new core/s. –  retracement Nov 22 '10 at 23:49
I am pretty certain you can change to multi-processor after the fact. –  SpacemanSpiff Apr 24 '12 at 21:09
I agree with @SpacemanSpiff... back in the XP/2003 days the HAL was either Uniprocessor or Multiprocessor. I don't think this is the case with 2008. –  Chris McKeown Apr 24 '12 at 23:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.