Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am installing abiword-2.8.6 on amazon ec2 instance

But it failing due to dependencies

Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libbonoboui-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgsf-1.so.114 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libbonobo-2.so.0 Error: Package: wv-1.2.4-4.el5.i386 (epel) Requires: libgsf-1.so.114 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libfribidi.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgsf-gnome-1.so.114 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomecanvas-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnome-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libORBit-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libglade-2.0.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libtermcap.so.2 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomeprintui-2-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomeui-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnome-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgconf-2.so.4 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgconf-2.so.4 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomeui-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomeprint-2-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomeprint-2-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libfribidi.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomeprintui-2-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgsf-gnome-1.so.114 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomevfs-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libbonobo-activation.so.4 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomevfs-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnomecanvas-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libORBit-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libglade-2.0.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libbonoboui-2.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libbonobo-2.so.0 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libbonobo-activation.so.4 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgsf-1.so.114 Error: Package: 1:abiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnome-keyring.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: libgnome-keyring.so.0 Error: Package: 1:libabiword-2.6.4-8.el5.2.i386 (epel) Requires: librsvg-2.so.2

Can anyone tell me do i need to resolve dependencies one by one .. or is there any alternate method to install with dependencies..

Thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Looks like you are installing via rpm.. First install EPEL

http://fedoraproject.org/wiki/EPEL/FAQ#howtouse

Then you can run

yum install abiword

That will install it an all requirements.

share|improve this answer
    
Thanks for the reply .. I am installing through yum and I have added epel to my yum also –  Padmanabha Vn Nov 17 '10 at 12:52
    
run the following command: cat /etc/*release* –  Mike Nov 17 '10 at 15:48
    
I launched new instance .. abiword installed without any problem.. thanks –  Padmanabha Vn Nov 19 '10 at 9:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.