Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm gettng constant Critical Issue events in the Small Business Server Best Practices Analyser & resulting SBS Console reports that begin "The DNS client is not configured to point only to the internal IP address of the server.". When I check the DNS Manager, there are two separate IPs listed, one ***.***.***.2 and the other ***.***.***.28. I have checked online after an ipconfig /all and have found the reason for this to be that the second IP is created by DHCP for RAS & VPN purposes. It seems to cause no conflicts of any detrimental result apart from constantly sending me error messages and alerted reports. Does anyone know of a way that I can change settings somewhere so that Windows accepts this second IP, or at least stops alerting me of its prescence? Perhaps a registry hack of some kind...?

Many thanks in advance

share|improve this question
add comment

2 Answers

All DNS IP address should be static instead of Dynamic also There should be one local IP address which is used in your internal network instead of using external IP address.

Can you share screenshot or something which makes us more understand how you have configured NIC? This would help to provide more accurate solution.

share|improve this answer
    
We do in fact use just one static, local IP on the server for DNS & use DHCP for machines connecting to the local network. We are having no actual connection problems & i understand fully why it's happening, I just really wanted a way to stop all of the error messages. What specifically do you need a screenshot of, IPv4 setting on the NIC...? Thanks –  evesirim Nov 17 '10 at 15:55
    
Yes, that would be helpful to understand what exact issue is. Have you tried to nslookup and check what address it is coming? Also, Though this is SBS 2008. I would prefer you check following link: support.microsoft.com/kb/825763 and blogs.technet.com/b/sbs/archive/2007/10/19/… –  maniargaurav Nov 17 '10 at 18:07
add comment

I had exactl the same issue with two DNS entries, with one caused by RAS connections. It was causing issues on the network, as when clients were trying to log on with logon scripts, it was resolving to wrong IP addresses and could take 10 minutes to logon. Easy fix though. In DNS server, Right click on the server, and choose properties. On the Interfaces tab, make sure that all interfaces are not ticked. Only tick the static one for your server. If use all interfaces is ticked, it registers the RAS entry into DNS as well, causing issues. Hope this helps.

share|improve this answer
1  
I've done this but it doesn't seem to work, the BPA still shows both IP addresses. –  Neil Apr 25 '12 at 13:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.