Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hy,

i have 1 central repository and many locals.
On my machine i have local and a central repository too.
I can make clone/commit/update/push/pull very easy between the local and central repository on my local machine. but when i want to make a clone from another machine it gets an error.

listening at http://MyLocalMachine:8000/ (bound to *:8000)
----------------------------------------
Exception happened during processing of request from ('192.168.0.194', 49319)
Traceback (most recent call last):
  File "SocketServer.pyc", line 558, in process_request_thread
  File "SocketServer.pyc", line 320, in finish_request
  File "mercurial\hgweb\server.pyc", line 47, in __init__
  File "SocketServer.pyc", line 615, in __init__
  File "BaseHTTPServer.pyc", line 329, in handle
  File "BaseHTTPServer.pyc", line 323, in handle_one_request
  File "mercurial\hgweb\server.pyc", line 79, in do_GET
  File "mercurial\hgweb\server.pyc", line 70, in do_POST
  File "mercurial\hgweb\server.pyc", line 63, in do_write
  File "mercurial\hgweb\server.pyc", line 127, in do_hgweb
  File "mercurial\hgweb\hgweb_mod.pyc", line 86, in __call__
  File "mercurial\hgweb\hgweb_mod.pyc", line 118, in run_wsgi
ErrorResponse
----------------------------------------

The command line wich started the central repo:

hg serve -R TT -n TTZoli

The command from remote machine for cloning:

hg clone --pull http://MyLocalMachine:8000/TT

Config for the central repo:

[ui]
username = MyLocalUserName
username = test <localemail@mail.com> 
with this user i'm trying to acces the central repo

[web]
push_ssl = false

Config for the remote repo:

[ui]
username = test <localemail@mail.com>     

[web]
push_ssl = false

I'm not sure if it's relevant,my firewall is turned off on both machines, and the files in /hg folder are not versioned on the server, except hgignore.

Could you please suggest some ideas?
What could be the problem?

Thanks in advance!

share|improve this question
add comment

2 Answers

Try with

hg clone --pull http://MyLocalMachine:8000

I haven't seen the -R option before. Is that from a plugin?

share|improve this answer
    
The -R is short for --repository. It is a global option which is why it isn's shown in hg help serve — use hg help serve -v to see it. –  Martin Geisler Dec 24 '11 at 1:49
add comment

What directory do you have the local repos serving from?

See this question, where that was the source of the problem..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.