Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a very slow RDP session from NYC to India (500ms) and we are looking for a client that will withstand this latency.

What do you recommend in this circumstance? Is there a better remote desktop solution that handles this type of connection? Perhaps one that is optimised for satellite connections.

share|improve this question

4 Answers 4

up vote 0 down vote accepted

SSH may be an option for some tasks. The command-line is much tolerant of latency.

share|improve this answer
    
Maybe as a stopgap solution, but working over an ssh connection with bad latency is horrible and it's not giving the nice gui environment that is required. –  kaerast Nov 18 '10 at 16:49
1  
Anything will be somewhat "horrible" with high latency. I would say SSH is quite a bit less horrible than a gui in this situation since it is at least deterministic. But, if your application requires a gui interface then you have only two choices: fix the app, or fix the latency. Sorry about that. –  JGurtz Nov 18 '10 at 17:59
1  
Perhaps Mosh would be a better choice than SSH? Mosh uses display update prediction to avoid the need for a round trip on every keypress. –  gmatht Dec 10 at 3:58
    
Big +1 for mosh! It even handles disconnect well, making it a good screen replacement on top of it! –  JGurtz Dec 15 at 17:59

A better connection. Point. No client can fix that.

We have sometimes 600ms and people complain - line overlaod.

Basically, the latency is there. All input is delayed 500ms. A client can not magically handle that. This is like asking "I like driving faster than allowed, what car color will help me not getting tickets".

share|improve this answer
    
+1. Network latency is network latency, nothing "software-y" you can do about it. –  Antoine Benkemoun Nov 18 '10 at 16:32

Since latency is the culprit there is not much an application can do to improve this.

The best bet is if you are using RDP then change the experience settings. Uncheck the allows for everything... "desktop background, font smoothing, visual styles, etc..." Also under local resources uncheck remote audio and under 'Display' display settings High Color 16bit.

share|improve this answer
    
-1: using less bandwidth does not reduce latency, at 0.5 seconds delay, a GUI is pretty much unusable. –  symcbean Nov 18 '10 at 16:04

Everyone's right, imho. If you feel like trying anyway in my experience the best is Teamviewer or Rammina.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.