Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Why is remote desktop so much faster (clicking UI elements, dragging/dropping, even the Start Menu opening/searching!) to the HOST OS, instead of to its virtual machines?

With several servers that I've connected both to the HOST OS and Guest OS in many Hyper-V setups, the virtual machines all seem very very slow while the HOST OS just flies, like it should.

The only thing I can figure is in all of these environments (4 of them across 3 networks), they all share the same NIC between the HOST and all VMs, even though Microsoft's recommendation is to have 2 NICs - one for the Host OS, and one or more for the Virtual Machine(s).

If this is the case, I can test this easily on my home network where I have my home server with Windows 2008 Server R2 running Windows Home Server in a Hyper-V. But, I don't want to spend the money for a good gigabit card if that is not the reason - hence, the reason for this question.

Thank you in advance!

share|improve this question
1  
This shouldn't be happening, at least not in my experience with Hyper-V R2. What guest OS's are you running on it? Are you using the synthetic virtual nic or the legacy virtual nic? –  Tatas Nov 18 '10 at 17:40
    
W2K8R2 for the host. The 1 VM locally is W2K3R2 (WHS actually). It's a Quad Core w/4 GB of ram - plently of resources. Configured for External connection type (if I understand your question). –  Eric Duncan Nov 20 '10 at 0:09

2 Answers 2

up vote 2 down vote accepted

Disable 'IPv4 Checksum Offload' on the virtual network adapter:

https://nicholasrogoff.wordpress.com/2010/09/24/

The virtual network switch in Hyper-V Server 2008 R2 supports syntetic and legacy interfaces. The syntetic nics will perfom better than the emulated legacy type, but it requires Hyper-V Integration Services to run on the guest VM. The integration components are fully supported in Windows Server 2003 SP2 and later versions of Windows.

http://www.virtualizationadmin.com/articles-tutorials/microsoft-hyper-v-articles/general/windows-server-2008-hyper-v-integration-services.html

BTW: there is a slight difference in using Remote Desktop to guest VMs and remoting with vmconnect.exe. Both use the RDP protocol (the software is based on the same library), but vmconnect.exe connects to the host environment which tunnels the communication to the guest.

share|improve this answer
    
+1 Thanks for the replies! I ended up using a 2nd nic for now, which seems to work. The next time I end up running Hyper-V on a single NIC setup, I will try your suggestion. For now, I'll mark it as the answer. –  Eric Duncan Apr 25 '11 at 5:29

If configuration of adapters in Hyper-V and supporting integration components in guest VMs is done with the best possible setup and remote desktop is still slow, please see the post below on disabling the Window Auto-Tuning throughput throttling:

http://blog.tmcnet.com/blog/tom-keating/microsoft/remote-desktop-slow-problem-solved.asp

netsh interface tcp set global autotuninglevel=highlyrestricted
netsh interface tcp set global autotuninglevel=disabled
netsh interface tcp set global autotuninglevel=normal
share|improve this answer
    
+1, thanks! –  Eric Duncan Apr 25 '11 at 5:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.