Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Ubuntu 10.04.1 (Lucid) running on a 2010 Mac Mini (4,1). It's a server, so I want it to be able to restart after a power failure ("server mode").

In Mac OS X, you can check "Start up automatically after a power failure" in the "Energy Saver" System Preferences. However, having this value checked doesn't seem to effect "server mode" behavior in Ubuntu (that is, it won't restart after a power failure).

This seems to be because the "server mode" value isn't persisted in pram/efi, but gets set by Mac OS X on every boot.

I found this tutorial on how to turn on "server mode" for a Mac Mini, but it doesn't work:

$ setpci -s 0:1f.0 0xa4.b=0
setpci: Warning: No devices selected for `0xa4.b=

A lot has changed with the new 4,1 Mac Minis-- just getting Ubuntu installed on it was quite a feat. Perhaps the "server mode" incantation has changed also?

My question is: how do I enable "server mode" on the new 4,1 Mac Minis?

share|improve this question
1  
Before voting to close, see: meta.serverfault.com/questions/968/… –  splattne Nov 27 '10 at 12:43
    
wow did this get reopened? –  paleozogt Nov 27 '10 at 16:42

1 Answer 1

up vote 3 down vote accepted

I found the answered buried in this post. The new setpci command is

sudo setpci -s 00:03.0 0x7b.b=19

btw, this setting isn't "sticky" and won't persist across reboots-- it has to be set upon each boot.

You can put this command in a bash script and run it on startup. See here for details on start-up scripts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.