Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to connect from my home computer to my office computer via Remote Desktop.

When my home computer is connected to the internet via my (wireless) router I get to the point where RDP asks for my username and password and after I do, it holds for a while at "Securing Remote Connection..." and then abandons without any error messages visible.

When I remove my router and connect my home computer directly to my home ADSL modem, it works fine. Why is it that the connection fails when going through my router?

Additional info:

  • I've been able to connect successfully via the router in the past.
  • In both cases above I am successfully authenticating against my office network through Shrew Soft VPN.
  • My home computer is running Windows 7, my office computer is running Windows Server 2008 R2.

Thanks in advance, urig.

Update:

Thank you all for your help. I've taken a good look at my router settings (it's a D-Link D-624 btw).

I've realized that when my laptop is docked it's connected both by a cable and by the wireless connection. I guess the wireless connection takes precedence because when I've changed the IP address mapped to incoming port 3389 I manage to get beyond the "Securing Remote Connection...".

Now I'm stuck at "Configuring remote session..." Any ideas? :)

share|improve this question

3 Answers 3

Do you have the ability to set up rules in your router?

In that case, you can open ports for incoming and outgoing traffic destined for port 3389. Some routers will let you select the name of the machine to forward the traffic to, or its ip address.

share|improve this answer

The only time this has happened to me is when I set my router up to forward the port to my PC's internal (to my home network)'s IP address... then the DHCP lease happens to expire and one of my kids PCs gets that IP address instead. Updating the router's port forwarding rules to match your new IP address fixes it, and/or adding a static entry by MAC address so that your machine always gets the same IP address.

share|improve this answer

RDP runs via port 3389, You'll need to forward the port on your router to the computer you're trying to access. Another option is to set the system you're trying to access as the "DMZ" host. However, the DMZ option will allow all traffic to be sent the system (possible security concern).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.