Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My domain name is not resolving correctly. It should resolve correctly to an IP address provided by my cable company. That address is dynamic. I run an app that updates the nameserver hosted at I look at my router's admin page and I see that my external address is a.b.c.d Yet my domain name is not resolving to this address.

At my domain name registrar, the DNS point to (NS1.EVERYDNS.NET, NS2.EVERYDNS.NET, etc). At my console, I see that my DNS A record is a.b.c.d, which is what it should be.

BUT when I do nslookup on my domain, it returns and answer of w.x.y.z. Even when I do a nslookup specifying the nameserver of everydns, it return w.x.y.x! I expected it to return a.b.c.d. How could this be?

share|improve this question
You'll probably want to provide your domain and host names if you want debugging assistance. We can then look at the DNS records and tell you what is wrong. I assume you want your domain's @ record to point at your dynamic home/cable IP? You'll need to either update each time your IP changes, or you might want to use a dyndns service instead. – mfarver Nov 19 '10 at 18:15
@mfarver, yes i use an app that runs every day to update the DNS record with my cable IP address. I've verified that the DNS A record is pointing to my home IP. Is there anything else I should check? Everything seems to be in order yet the resolution is not correct. – Sajee Nov 19 '10 at 18:27

1 Answer 1

up vote 1 down vote accepted

At the moment I'm not getting any response from or

It seems EveryDNS was taken over by DynDNS. Maybe they are discontinuing some old services in the belief that everyone transitioned to the DynDNS branded service? Maybe they are just having technical problems?

I would contact and then DynDNS support.

share|improve this answer
I tried "nslookup" and it's returning the expected IP. So things are working correctly again. Not sure what happened. Must be something on everydns's side. – Sajee Nov 19 '10 at 20:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.