Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install a library called libtool

i am getting "./configure: line 2668: libltdl/config/mkstamp: Permission denied" when i do ./configure

how can i chmod a+x all the libtool directory to prevent this error ?

thanks

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

Be careful before making permissions changes so deep like this. Before you start, make a backup:
cd libtool
find . -printf "chmod %m %p\n" > ~/perms.txt
Then, to change to make the whole thing a+x (bad idea, but meh):
find . -exec chmod a+x '{}' \;

If anything goes wrong, you can always revert afterwards:
cat ~/perms.txt | bash

share|improve this answer
    
chmod -R is better and way less complicated –  aspitzer Nov 19 '10 at 21:35
    
That's already been mentioned on two other answers. You're right in that it's less complicated and faster, as were @skinp and @ramesh earlier. –  James Lawrie Nov 19 '10 at 22:31
add comment

Most version of chmod have a recursive flag:

chmod -R a+x folder
share|improve this answer
    
I have no idea why I forgot about that! –  James Lawrie Nov 19 '10 at 19:56
    
Is it possible to do that without crossing FileSystem boundaries ? I have a NFS mount somewhere in the folder tree that I don't want to chmod. –  Natim Aug 8 '13 at 15:42
add comment

chmod -R +x /path/to/folder will work though

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.