Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two Exchange servers running in the same domain. One Exchange 2003 and one Exchange 2010. I've managed to setup bidirectional routing. I have moved some mailboxes via a "Local move request" on Exchange 2010, this was completed succesfully.

My problem: When I go to the "old" OWA 2003 site (https://legacy.company.com/exchange) and login with the user/pass of amailbox that has been moved, I am redirected to hxxps://newserver.domain.local/exchange. I'd like to be redirected to hxxps://newserver.company.com/exchange or hxxps://newserver.company.com/owa.

I've already setup the OWA url's of the new Exchange server to use newserver.comapny.com instead of newserver.domain.local, using the Set-OwaVirtualDirectory cmdlet.

PS. I've found out that the old OWA 2003 uses a HTTP 302 (permanent move) http response which redirects to the internal FQDN of the Exchange 2010 server.

Where can I setup the FQDN/URL that OWA 2003 redirects to when a mailbox is found on the new Exchange 2010 server?

If anybody has an idea I'd be much oblidged.

share|improve this question

3 Answers 3

You're doing it backwards - is there a reason for this?

This is the way it's supposed to work.

  • Before you install Exchange 2010, you have Exchange 2003 on https://mail.acme-widgets.com
  • You create legacy.acme-widgets.com and make sure your firewall forwards traffic destined for this to Exchange 2003
  • You change DNS records/firewall rules so traffic destined for https://mail.amce-widgets.com is now forwarded to Exchange 2010.

When you do this, any users whose mailboxes are on Exchange 2010 will use the Exchange 2010 OWA that they have logged in to (using the external or internal URL), and any mailboxes on Exchange 2003 are forwarded to an Exchange 2003 server that you specify.

To set the URL your Exchange 2003 users are sent to, run this cmdlet Set-OwaVirtualDirectory <Your OWA Virtual Directory> -Exchange2003Url https://legacy.acme-widgets.com/exchange.

share|improve this answer
    
Hi Ben, Thanks for your reply. Indeed I know what I'm asking for is 'backwards'. The reason I'm a bit hesitant to change the DNS of mail.acme-widgets.com to Exchange 2010 is because a lot of users are using this FQDN to connect to Exchange on their phones. When I change the DNS will those phones still be able to sync? Does the 'silent redirection to Exchange 2003' for yet unmoved mailboxes work for ActiveSync as well? –  mat0ng Nov 21 '10 at 10:49

For your ActiveSync question, the ActiveSync traffic is proxied by the Exchange 2010 CAS to the Exchange 2003 mailbox server, not redirected like OWA traffic.

For this to work you first need to enable integrated authentication on the ActiveSync virtual directory on Exchange 2003. This involves installing a patch and then making the change via Exchange System Manager.

You'll find the steps here, towards the bottom of the page:

http://technet.microsoft.com/en-us/library/ee332348.aspx

share|improve this answer

I've had this same problem.

As far as I can tell, the answer is you can't really do it, shy of using something to proxy. In Exchange 2003 you can set up a front end server to act as an ActiveSync proxy for multiple back end servers, but Exchange 2003 front end isn't going to be able to do that for an Exchange 2010 server.

There are some third-party proxy solutions that could probably get you this. Myself, I have experience with F5. But unless you have hundreds and hundreds of users, it's hard to justify the time and expense of setting up a proxy.

What I ended up doing was staggering mailbox migrations. I left all the mailboxes still on the Exchange 2003 that worked with the old DNS name, and when I was able to take time to talk to users, tell them what was happening, and help them change their mobile device settings, that's when I migrated their mailbox to the new server with a new name in DNS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.