Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

it's the first time i use postfix and i'm having some problem configuring it. It does send mail to the "real" out world, but i'm not capable to recive mail sended from the web. I think there's an hosts misconfiguration with host, i've tried some solution but none had effects

The server is running Debain Stable (Lenny)

cat /etc/hostname


cat /etc/hosts       localhost hosting mail

cat /etc/postfix/

myorigin = $mydomain
myhostname =
mydomain =
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = localhost, /etc/postfix/local-domain
mynetworks_style = host
relayhost =
mynetworks = [::ffff:]/104 [::1]/128

cat /etc/postfix/local-domain

cat /etc/postfix/local-domain

mailer-daemon: postmaster
postmaster: root
nobody: root
hostmaster: root
usenet: root
news: root
webmaster: root
www: root
ftp: root
abuse: root
noc: root
security: root
info: artkiller
root: artkiller

I'm not sure, maybe it could be a DNS configuration problem. This are the relevant DNS record:

MX          10   

Hope i give you any useful information - thanks for help


share|improve this question

1 Answer 1

up vote 4 down vote accepted

The A record for is missing.

share|improve this answer
You are right: Host not found: 3(NXDOMAIN) – lrosa Nov 21 '10 at 14:33
You're right - a misconfigurated the A record for mail.artkiller-web, i've just modified it to match "" and i'll wait for propagate. If it'll work i'll mark the question as answered – ArtoAle Nov 21 '10 at 14:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.