Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I tried everything I could but still cannot remote desktop to a laptop running Win 7 at home.

Basically, I made sure rule exists for TCP 3389 connections to be allowed, no local policies restrict it, etc, but still no luck, System|Remote enables it, all kinds of connections are accepted, etc etc: firewall log shows

... DROP TCP ... 3389 ... RECEIVE

I cannot telnet into that port from the same client box I'm trying to RD from.

Any help is appreciated.

EDIT: How can be known which exact firewall rule or policy is being applied to decide to reject a packet? Is that info contained somewhere?

share|improve this question
    
Can you connect to it from within your own network? Is it set to require network level authentication? –  sinping Nov 22 '10 at 13:24
    
Are you connecting from work? if so they could have a firewall that is blocking that port outgoing –  Trozz Nov 22 '10 at 13:29
    
Client and server are connected to my same home LAN. For some reason (either a policy or a firewall rule that is taken precendence over the RD one), connection attempt to 3389 is getting blocked. –  Ariel Nov 22 '10 at 13:34

1 Answer 1

The firewall log holds the answer:

... DROP TCP ... 3389 ... RECEIVE

It looks to me like the firewall is dropping the incoming RDP connection.

share|improve this answer
    
Sure... my question is why that's happening :-) –  Ariel Nov 22 '10 at 13:56
2  
I don't understand what you don't understand... "Why is is happening?" Because it's being blocked by the firewall. Take another look at the firewall rules. It may be that the firewall rule is set to be a private network rule and not a public network rule. –  joeqwerty Nov 22 '10 at 14:33
    
That's what I'm saying... there's a rule enabling Remote Desktop for public, home/work and domain network profiles, still connection attempt is being dropped... –  Ariel Nov 22 '10 at 16:02
    
Well, I fixed it... my home network was being set as Public in my server box. Set it to Home and worked. What's confusing is that my firewall rule enabling RD was for all profiles... Thanks. –  Ariel Nov 22 '10 at 16:41
    
That is strange, glad you figured it out. –  joeqwerty Nov 22 '10 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.