Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to SSH to a mysql DB on my web server.

First I tried using PuTTY on windows 7. put in my domain and clicked open. A command prompt comes up and asks me for a user. I put in my ftp user name and hit enter. I am then asked for a password. I put in the FTP password, the command line closes. Now what?

I then tried using ubuntu. I ran $ ssh myftpuser@mydomain.com I was then asked for a password. I put my ftp password. I was told Permission denied.

I do not know what to do. I have never used SSH before, I have always used phpmyadmin for MySQL. The only reason I am trying to use SSH now is because I tried to create a TRIGGER and was told I need SUPER privilege for this. I asked the hosting DBA and he told me I should connect using SSH.

share|improve this question
    
askubuntu.com –  djangofan Nov 22 '10 at 22:30

3 Answers 3

up vote 2 down vote accepted

Clearly, your FTP username and password do not have access to this server. You'll need to secure permissions from whoever manages the server.

share|improve this answer

ssh uses your shell account user-id and password.

If you don't have a shell account it won't work. FTP clients can have their own user/password databases.

Contact the administrator of the server to get your shell account user-id and password. Change the password after your first login.

share|improve this answer

Looking at another one of your posts, it looks like you might be using a hosting provider that provides SFTP access (which is based on SSH), but not SSH shell access. A lot of hosting providers don't provide shell access anymore without requesting it or not at all. But they still might provide SSH access in order to use SFTP.

If all you are wanting to do is transfer files then I'd suggest using WinSCP under Windows or use the sftp program or gFTP from Ubuntu. If you're truly wanting to access a shell on that server I would contact their support and see if its allowed first or if it needs to be activated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.