Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to migrate VMs between ESX3.5 host and ESX 4.1host.

After exporting by Virtual Appliance->Export in ESX 3.5, an .ovf file and a vmdk file is created. I couldn't find any way to add to inventory on a ESX 4.1 host with vCentre.

There is no .vmx file for me to right-click add to inventory as found in some instructions.

Do I have to use VMware vCenter Converter Standalone or use ovftool instead?

I have tried the following steps: 1. Virtual Appliance->Export to create .ovf file. 2. Try to convert .ovf to .vmx file using ovftool so that it can be added by right clicking .vmx file on ESX 4.1 host.

It might not even be necessary to do step 1 and convert .vmx to ovf directly using ovftool. I'm not sure after converting to ovf using ovftool, would I be ending up with the same scenario that I wouldn't be able to add to ESX 4.1 host inventory?

Any help is greatly appreciated, thank you.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Once you export the Appliance from 3.5, all you need to do in 4.1 to import it is File -> Deploy OVF Template. Then simply file the dialog boxes and choose the exported .ovf file as your source.

In the scenario you've described, there is no reason to use the Converter nor the ovftool to deploy the VM.

share|improve this answer
    
Thanks Jed! I did explore this option before, but it didn't allow adding ovf file from datastore so I didn't explore further, as I have copied across the exported ovf to the new datacentre datastore with Veeam FastSCP. I will try this option again. –  Imagineer Nov 23 '10 at 2:46
    
Do you know if its possible to install vSphere Client on the same machine running viClient? The last time when i tried, it prevented me from logging in to my old Virtual Centre. –  Imagineer Nov 23 '10 at 2:53
    
All you have to do is attempt to login to the old 3.5 ESX system with the "new" vSphere client, and it will automatically download the necessary components and work with both versions forevermore. –  Jed Daniels Nov 23 '10 at 5:18
    
Thanks Jed, it works! That is what I had missed, I thought I need to login to old ESX 3.5 with old viClient. Much appreciated. Cheers... –  Imagineer Nov 24 '10 at 6:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.