Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The company I work for is using SharePoint as a CMS for it's public facing website. I recently enabled FBA (Forms Based Authentication) for the site in order to provide some user specific functionality, but this has caused a side effect with Word / Excel files when opened from the site using Office 2007 / 2010.

Some users are challenged for authentication when opening a Word / Excel document from IE (but not when they're select "save file" instead of "open file"). A window pops up behind IE / Word / Excel (so you often don't realise it's there) showing the sites login page. If the window is dismissed then the document continues to open normally.

It seems to be environmental. Most Office 2007 / 2010 users internally experience this and we've had one report externally of this happening.

Anyone know how to prevent this behaviour?

In case it's relevant: The company also has an internal SharePoint site using NTML authentication allowing internal users to edit the same content visible externally.

I originally suspected the SharePoint header added to responses may be alerting Office to check for authentication to allow extended functionality, but I remove the response header in IIS and it didn't make any difference.

share|improve this question
    
This is happening for un-authenticated users (and probably authenticated users I should imagine). The redirect to login page is a side effect of adding the FBA to the site. It currently shows our custom login page, but from what I understand if we didn't have a custom login page it would just be redirecting to the standard sharepoint login page. The problem really is that it's asking for authentication when the file should be downloadable from the public facing site for anonymous users (which they can after dismissing the login screen). –  Gavin Nov 25 '10 at 20:24
    
I've cross posted to Microsoft's oven Sharepoint forum and a little more detail is available there - social.msdn.microsoft.com/Forums/en/sharepointgeneral/thread/… –  Gavin Nov 25 '10 at 20:26

1 Answer 1

I tried to open a few documents from the http://ecan.govt.nz/services/resource-consents/pages/forms-booklets.aspx#application-forms page using different browsers and the problem only occurs for Internet Explorer.

Try setting the Enable Client Integration option to No in configuration of the Internet zone authentication provider.

UPDATE:

An article that may help has just been published - SharePoint 2007: Office Documents prompt for Authentication when trying to open from SharePoint site.

This happens when Office detects that WebDAV is enabled on the server. If WebDAV is enabled then Microsoft Office also has to determine whether or not to open the document as ReadWrite or ReadOnly. SharePoint acts as its own WebDAV Server. Server 2008's WebDAV Publishing role if enabled will interfere with SharePoint’s WebDAV functionality.

share|improve this answer
    
Hi Marek, thanks for that. You're correct - it's only an IE issue. Unfortunately the "Enable Client Integration" to "No" makes no difference for us. I originally tried this, and have now tried again just in case, but we still experience the same issue. This setting has now be applied to the live site. –  Gavin Nov 30 '10 at 0:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.