Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

-- Cross posting from stackoverflow --

I'm new to qmail and I'm responsible for figuring out how the current mailservers are setup. I needed to add a user for There was a perl script at ~/addaccounts that reads an 'accounts' file to create accounts. I tried both that and using the vadduser script directly. They both created the /andrew/ directory and Maildir structure, but when I attempt to send an email, I get the following error:

Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 511 511 sorry, no mailbox here by that name (#5.1.1 - chkuser) (state 14).

That user is able to login to POP fine and logs say it was successful, but when an email is sent from any email account (Google was used here, but I've tried others), I get the above error.

Things I've tried:

  • Restarting the qmail process
  • Adding a user both from ~/addaccounts and vadduser (former uses the latter anyway)
  • Create all the directories manually
  • Used "telnet localhost 25" to attempt to send mail to and got a "250 ok" message along with other emails that do not exist (set to bounce-no-mailbox I believe).

Any help is appreciated.

share|improve this question

If you have changed your server recently or reset the mx records then you should wait 24 to 48 hrs. there might be a caching issue on some of the other servers.

share|improve this answer
Had the guy I'm working for talk to a previous administrator for the servers and I didn't realize I had to add accounts on the relay server as well (it's a multiple server setup). So my tests on the single server worked, but the emails didn't get past the relay server to the main server. It was the relay server that was spitting out the issue. – Andrew Ryno Nov 25 '10 at 4:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.