Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I thought that it was because of two machines on the network having the same hostname, and hence asked this question. But it did not resolve the problem. The machine responds to my pings. But when I go to Places > Network, I can't view that machine. I also can't view the other machines on the network from his machine. What seems to be the problem?

EDIT: I can view the folders using the samba protocol, by typing this in nautilus:
smb://192.168.1.5

But I cannot access the tomcat running on his machine, by typing this in the browser:

http://192.168.1.5:8000

There is a mac-mini in my office, and that can view this machine, and vice-versa.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Viewing the computer in Places > Network is based on a different protocol. Ping is a very low level debug tool. It does not scan the network and build a list of other computers on the network.

SMB (Windows File Sharing) is a set of protocols and programs that communicate to provide that list of what computers are on the network and what folders they are sharing. Along with sharing files itself.

By default (and unlike windows), Ubuntu does not come with SMB (Called Samba in Linux) turned on by default. A Windows box will not see a Ubuntu box in Network Neighborhood (or Network Places, or whatever Microsoft is called that now days), if Samba is not installed and turned on in Ubuntu.

In Ubuntu 10.04 it's real easy to do. Take a look at this guide. http://www.simplehelp.net/2007/05/19/how-to-share-files-and-folders-in-ubuntu/

Once you have something set to shared, other computers will then see that computer on the network.

share|improve this answer
    
I can do a smb://<address> to browse the shared files. However, Its not available in the Network Places, and thats what I miss. –  theTuxRacer Dec 4 '10 at 10:18

Linux default do not allow access in network neighbourhood - in this window You will see only SMB hosts which mean: windows, or Linux with samba enabled and running. So probably You do not define smb shares on Your machines - define some shared directories ( in Gnome right context menu on folder - option "share this directory" or so).

share|improve this answer
    
I have defined shares on all PCs, but still I cant see those PCs. –  theTuxRacer Dec 4 '10 at 10:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.