Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently trying to create a Samba share on a lightweight home network, and I'm having a bit of trouble configuring Samba 3.5.6 compiled from the ports tree.

What I'm looking for is pretty basic. I just want a share with no limits, that anyone can have access to on my home network. More specifically, I do not and will not ever need printing.

/usr/local/etc/smb.conf looks like this:

#======================= Global Settings =====================================
[global]
   workgroup = WORKGROUP
   server string = Server
   security = user
;   netbios name = Server
   hosts allow = 192.168.1. 127.
   log file = /var/log/samba/log.%m
   max log size = 50
   interfaces = 192.168.1.254/24 192.168.1.253/24
   wins support = yes
   guest account = ftp

#============================ Share Definitions ==============================
[drop]
   comment = Server Drop
   path = /usr/drop/
   public = yes
   writeable = yes
   printable = no
;   admin users = User
   browseable = yes
   guest ok = yes
   hide dot files = yes

And when I run testparm I get the following output:

$ testparm
Load smb config files from /usr/local/etc/smb.conf
max_open_files: sysctl_max (11095) below minimum Windows limit (16384)
rlimit_max: rlimit_max (11095) below minimum Windows limit (16384)
Processing section "[drop]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        server string = Server
        interfaces = 192.168.1.254/24, 192.168.1.253/24
        guest account = ftp
        log file = /var/log/samba/log.%m
        max log size = 50
        wins support = Yes
        hosts allow = 192.168.1., 127.

[drop]
        comment = Server Drop
        path = /usr/drop/
        read only = No
        guest ok = Yes

However, when I try to test this connection locally with smbclient \\\\localhost\\drop\\ I get the following output:

$ smbclient \\\\localhost\\drop\\
Enter User's password:
Connection to localhost failed (Error NT_STATUS_INVALID_PARAMETER)

I have also come across a similar issue at http://stackoverflow.com/questions/4034380/why-smb-returns-nt-status-invalid-parameter-how-to-fix-smbclient, but that's amazingly vague and doesn't come with a solution.

Any advice on what to fix?

EDIT: It appears the problem may go deeper than this. Despite the line samba_enable="YES" in /etc/rc.conf, and despite restarting samba a few times after bootup, running ps -ax | grep mbd to see what's running gives me:

$ ps -aux | grep mdb
root   1802  0.0  0.1  7044  1348   0  R+    9:41PM   0:00.00 grep mdb

Implying that Samba isn't even running, despite all my....

$ /usr/local/etc/rc.d/samba restart
Performing sanity check on Samba configuration: OK
smbd not running? (check /var/run/samba/smbd.pid).
nmbd not running? (check /var/run/samba/nmbd.pid).
Removing stale Samba tdb files: ...... done
Starting nmbd.
Starting smbd.
share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Removing the lines:

wins support = yes
guest account = ftp

And changing the line

interfaces = 192.168.1.254/24 192.168.1.253/24

to

interfaces = wlan0

And then performing:

$ /usr/local/etc/rc.d/samba stop
smbd not running? (check /var/run/samba/smbd.pid).
Stopping nmbd.
Waiting for PIDS: 2219.
$ /usr/local/etc/rc.d/samba status
nmbd is not running.
smbd is not running.
$ /usr/local/etc/rc.d/samba start
Removing stale Samba tdb files: ....... done
Starting nmbd.
Starting smbd.

Appears to have resolved the issue. I guess there was either a clash with wins support, or the guest account ftp didn't exist or some such silly business.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.