Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have an app that can use mssql2k or 2k8. We've been using 2k but I decided to try 2k8 to compare. I installed in on our win2k3 server alongside mssql2k. In the ODBC applet on the server, I was able to set up access to 2k8, and it passes the test at the end successfully, whether I tell it to use Windows Authentication or an sql login. The latter is how the app always accessed mssql2k. The app works fine from the server, but when I try it on a workstation (winxpsp3), I get a window titled, "Microsoft SQL Server Login" that says:

Connection failed:
SQLState: '01000'
SQL Server Error: 53
[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).
Connection failed:
SQLState: '08001'
SQL Server ERror: 17
[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.

Then I get the ODBC login dialog, which I can't get to login correctly (I just keep getting the same error above), even copying and pasting a password after resetting it on the server, and whether "trusted" is checked or not. "Options" is disabled.

The server was straight SERVERNAME for mssql2k, but for mssql2k8 it's called SERVERNAME\mssql2008. That works on the server, why not on the workstation? (Which I'm logged in as the same person on, BTW.)

share|improve this question
up vote 5 down vote accepted

See this related question: How to enable remote connections for SQL Server 2008?

share|improve this answer
Thanks, it ended up being that TCP/IP wasn't enabled (remote connections already were, though, for whatever reason.) – Kev Jun 5 '09 at 20:40
(I tried entering the question different ways, but I guess I never hit the right combination...) – Kev Jun 5 '09 at 20:41

Did you enable remote connections? That's most likely the issue.

You need to use the SQL Server Configuration Manager to do this for 2008. Instructions on MSDN Books Online here.

Hope this helps.

share|improve this answer

If the enabling remote connections does nothing for you check the TCP/IP settings by going to the Sql Server Configuration Manager. Expand the SQL Server Network Configuration item and then click on protocols for 'Your Instance Name (mssql2008)'. TCP/IP should be enabled, if not do so. Then go to properties for TCP/IP. Make sure that it is not using dynamic ports unless there are no firewall restrictions. If there are firewall restriction go to the bottom were it say IPAll and then TCP Port and enter a port number like 1435. Then enable this port in the firewall and try again.

share|improve this answer

Did you check the Windows firewall settings on the server? You'll have allow TCP port 1433 (incoming).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.