Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently install ArchBang on a machine with Ubuntu and XP. I ran update-grub from Ubuntu and it found the new install and created an entry. However, when I try to boot it, I get:

error: out of disk
error: you need to load kernel first

I've tried several things, including adding a new entry in 40_custom, but nothing changes. Here are the entries I have: default found by update-grub

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "ArchBang Linux (on /dev/sda4)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos4)'
    search --no-floppy --fs-uuid --set 75f96b44-3a8f-4727-9959-d669b9244f2a
    linux /boot/vmlinuz26 root=/dev/sda4 rootfstype=ext4 ro xorg=vesa quiet nomodeset swapon
    initrd /boot/kernel26.img
}
menuentry "ArchBang Linux Fallback (on /dev/sda4)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos4)'
    search --no-floppy --fs-uuid --set 75f96b44-3a8f-4727-9959-d669b9244f2a
    linux /boot/vmlinuz26 root=/dev/sda4 rootfstype=ext4 ro xorg=vesa quiet nomodeset swapon
    initrd /boot/kernel26-fallback.img
}
### END /etc/grub.d/30_os-prober ###

custom entry in 40_custom based on various ideas found on the internets

menuentry "ArchBang Linux (on /dev/sda4)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos4)'
    search --no-floppy --fs-uuid --set 75f96b44-3a8f-4727-9959-d669b9244f2a
    linux /boot/vmlinuz26 root=/dev/disk/by-uuid/75f96b44-3a8f-4727-9959-d669b9244f2a rootfstype=ext4 ro xorg=vesa quiet nomodeset swapon
    initrd /boot/kernel26.img
}

I think the problem has something to do with the sda4 not being mounted at boot-time...

Thanks in advance for you help,

Sam

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I figured out the problem. It was a BIOS / big disk problem. The computer in question is a Dell Inspiron 6000 from 2005. It came with a 40gb disk, which I replaced with a 160gb disk. The Archbang partition started at about 90gb in, and apparently this caused the problem.

After successfully booting with a SuperGrub2 disk using the "Enable PATA" option, I found on their site that you could reinstall grub with the ATA module and it now works fine, though I find that the boot up time is longer :(

So if anyone encounters this problem on an older machine with a large disk, this could help you overcome it :)

First try booting with SuperGrub2 with the Enable PATA option. If that works, then, from a working linux install, reinstall grub like this:

grub-install --disk-module=ata
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.