Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have some emails which are been deleted as spam and the AgentLog files contains the section

... Sender Id Agent,OnEndOfHeaders,DeleteMessage,,MissingPRA,No valid PRA,

I would like to configure Exchange 2007 not to reject emails from this particular domain.

I thought it was a matter of using the PowerShell command

Set-SenderIDConfig -BypassedSenderDomains domainname

but this does not seem to make any difference.

The domain in question does not have any SPF record set.

Any ideas?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

(I've dug up a few bookmarks for this, so I could be barking up the wrong tree)

The PRA is the 'Purported Responsbile Address' http://tools.ietf.org/html/rfc4407. It doesn't look for that until phase 5 of the message's run through the gauntlet of IMF http://technet.microsoft.com/en-us/library/aa997242(EXCHG.80).aspx; and it's a preulde to the SPF check.

I've never seen it listed as 'Missing' before, since it's Microsoft's own algorithm that's responsible for determining it. Perhaps an earlier phase has already rejected all of the recipients at the SMTP stage, leaving a directionless message that gets flagged for deletion. I don't think the sender domain whitelist applies at this point, though. If you can, try to catch a few messages from the sender as they come in and look at the SMTP conversations. Perhaps their MTA is mangling a standard header in a way that's causing this (unlikely, but it's where I'd look next).

share|improve this answer
    
Looks like you are barking up the right tree. The email is an automated report from a program and it looks like the FROM is set to the program name rather than a valid email address. So now, it is just a matter of getting the vendor to configure their software correctly. Thanks for your help. –  sgmoore Nov 30 '10 at 10:10

For some multi-valued attributes, PowerShell does not have an "add" command that adds to the list.

For such attributes, use the following commands: $foo = get-contentfilterconfig

$foo.BypassedSenderDomains += somedomain.com

$foo | set-contentfilterconfig

To get a list of all bypassed domains: get-ContentFilterConfig | select BypassedSenderDomains

Hope this would help you

share|improve this answer
    
+1 to that. Also bear in mind that the command in the original question will overwrite the array of domains set using this method, so be careful with your powershell... –  SmallClanger Nov 25 '10 at 20:22
    
I am aware of that issue and always check the before and after results whenever I change anything. In this case there were no pre-existing entries and the setting is definitely correct. –  sgmoore Nov 26 '10 at 9:19

You may need to restart the transport service before the change takes effect.

share|improve this answer
    
I'll try that. I should know tomorrow if it works. –  sgmoore Nov 25 '10 at 19:51
    
Ok, I've never had any problems with adding those entries on the fly...just throwing it out there as a possible cause. –  CurtM Nov 25 '10 at 19:56
    
Unfortunately, restarting the transport service had no effect. –  sgmoore Nov 26 '10 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.