Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We're upgrading from MediaWiki 1.13.2 -> 1.15.4. One of the issues we see is that when a page is searched for which in which the page name contains special characters, the page cannot be found.

Specifically, if the page is called A&B (A ampersand B) and I type A in the search field it will (correctly) show me A&B as a search suggest. When I select A&B I will go to a page marked A with this message:

There is currently no text in this page. You can search for this page title in other pages, search the related logs, or edit this page.

The URL will be correct: <fullURL>/A%26B

(This is also seen if I press Random page several times until I come across this.)

Anyone know how this can be solved?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Solved it. Our LocalSettings.php had:

$wgArticlePath = "${wgScriptPath}/$1";

I removed this line which then gave title= in the URL. I resolved this by adding:

$wgUsePathInfo = true;

to LocalSettings.php

The only disadvantage is that /index.php is added to all the URLs. If anyone can solve that I'll gladly vote up! =:-)

share|improve this answer

See the the Short URL article on MediaWiki.org for some details that may help you including a few options for fixing it.

share|improve this answer
    
I Googled for ages but did not find this, thanks. I won't investigate further because I now have a working solution but this is useful info. –  Wikis Nov 26 '10 at 15:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.