Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having difficulty getting something that should be simple going. I have a Netgear DM111P modem connection to a broadband connection using PPPoA. Connected to this I have a Netgear FCG318 wireless router/8 port switch. This serves about a dozen users in a small office mostly wireless clients and some wired ones.

The modem is defaulted to act as a DHCP server when using PPPoA and if I have the DHCP disabled on the router nobody can connect to the internet as there not being assigned an IP. So the only way to connect is to specify an IP and everything works smoothly.

So the crux of the problem, I need to have DHCP enabled on the router so that users can connect but this seems to be causing the internet to fail within an hour of both modem and router being rebooted. What I suspect is that both are fighting for the right to assign IP's and eventually locking each other up as when the internet goes down I cant connect to either modem or router admin interfaces. Adding to this there seems to be an unusually large number of packet collisions on the network something like 3% of total traffic.

another curio seems to be the fact that they will not work when given the same class of IP ie currently the modem is 192.168.0.1 and the router 192.168.1.1 if i make them both 192.168.1.* respectively they refuse to cooperate.

So finally two questions, is the DHCP causing the router and modem to fight to the death and kill each other along with the internet connection and how to i resolve this.

What would be the correct IP address setting for the router and the modem given that I need the router to act as DHCP butcant disable the modem as the connection has to be PPPoA(its on the BT network in the UK).

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If things are connected correctly then the 2 DHCP servers don't/won't conflict as they are on different subnets and the router won't pass that traffic. The subnets must be different, this is normal. Please confirm:

  1. The modem LAN port cable is connected to the router WAN port, NOT a LAN port.
  2. The router WAN port is set to DHCP.
  3. The router LAN IP and the modem LAN IP must be on different subnets. Ex. If modem LAN IP is 192.168.0.1 then router LAN must be something else, 192.168.1.1 will work.
  4. NAT is enabled on the router.
share|improve this answer
    
Ed all of the above are correct I will need to check No 4 when I get back in the office on Monday (connection has gone done again so cant log remotely to a local machine to check things) but for the moment I will say I'm 90% sure NAT is enabled. –  seanl Nov 27 '10 at 12:46
    
We will need more info to help then. Pls post specific IP's for all interfaces on both devices. The two ways it can be wrong but sort of work are #1 & #3. DHCP servers don't fight because they don't broadcast, they only listen and respond to received lease requests. They can hand out duplicate IP's though which will cause problems. This can only happen if the 2 devices are cabled incorrectly so that the 2 LAN's are connected instead of WAN-LAN. –  Ed Fries Nov 27 '10 at 18:09
    
Ed to clarify and in order of your questions above, 1)Modem lan cable is connected to router WAN port. 2) WAN port is set as DHCP (it is set to receive an address through the autosensing capability) when i look at the WAN status it is receiving an external address from the Modem.. 3)Router IP is 192.168.1.2 modem IP is 192.168.0.1. 4)NAT is enabled network –  seanl Nov 27 '10 at 22:57
    
Good info but pls be more specific: LAN IP of modem=?, WAN IP of router=?, LAN IP of router=? –  Ed Fries Nov 28 '10 at 2:52
    
Ed Lan IP of modem is 192.168.0.1 WAN IP of router is XX.XXX.X.XX LAN IP of router is 192.168.1.2 I made some changes last night and it seems to be holding up, although I wont know for sure till tomorrow and it gets some traffic on the LAN to test things out properly –  seanl Nov 28 '10 at 13:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.