Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an ancient celeron-based Windows 2003 SBS server on an old Dell machine. It has a very basic IDE non-RAID setup. The server is so old, it takes about 30 minutes to boot up and log in.

A new Dell (ugh!) server was purchased with the intent of doing a ghost from one server to the other. The new server has a PERC6/i RAID controller in in w/ SATA drives.

Copying the data works fine (using linux 'dd'), but the server refuses to boot with 'STOP 0x0000007B (0xF789EA98, 0xC0000034, 0x00000000 0x00000000)'

In my experience, this has been due to Windows not having the drivers for the RAID controller.

To fix this, I would boot the old server, download the drivers for the new server, extract them, right-click on the .inf file and hit 'Install'. Then shutdown and start the copy process.

It's totally not working for me with this new Dell server. I am certain I have the correct drivers--I used the driver from the CD that came with the server, and I also went online and downloaded the correct driver. But the new server refuses to boot.

Does anyone with more experience with this have any pointers?

share|improve this question

4 Answers 4

If you have the option, installing the drivers before ghosting is the preferred method for doing this. Windows SHOULD pick up the new drivers during the boot process on new hardware. This is a large part of how Physical-to-Virtual migrations work driver-wise.

share|improve this answer
    
That is what I've done in the past, and exactly what I did this time, but I still get the blasted stop error. –  Aaron C. de Bruyn Nov 27 '10 at 23:22
1  
Some drivers have services that need to be installed and configured to start. Just right clicking the INF isn't always good enough. Stop 7B is "No drivers for boot device". –  Chris S Dec 6 '10 at 1:39

I've had lots of similar problems with IDE RAID 1 and Windows being unable to boot. It might be this specific error.

The discussion has been that IDE RAID isn't "real RAID", meaning that the OS is really still aware and doing some of the work.

If using RAID 1 on the original box, one idea that has come closest to working for me is to break the mirror and then go through the rest of your process.

share|improve this answer
    
I goofed--I meant to say non-RAID setup on the old server. It's a single IDE drive. I just tried updating the IDE driver in device manager to use Microsoft's generic drivers. It takes about 6 hours to copy the data to the new server. I'll post my results back. –  Aaron C. de Bruyn Nov 28 '10 at 1:49
up vote 0 down vote accepted

Dell tech support confirmed it is a bug in their drivers when the source server is not up to SP2. Their fix is to install SP2 and retry the transfer.

share|improve this answer

A big thumbs up to DriverInjection

I did a disaster recovery of backups from a physical machine restored into a VM. I had the exact same error as the OP. DriverInjection + devcon.exe let me get an unbootable VM running.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.