Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a NAS which runs a custom linux distribution (it's a QNAP). uname -a -> linux 2.6.30.6 #1 SMP ... i686 unknown

I've set it up to do key and password-based multiple-user authentication, and that has worked for awhile. It's running OpenSSH_5.4p1, OpenSSL 0.9.8n 24 Mar 2010.

I run a dyndns client on the host, so there are two ways to access it:

ssh user@host.local

ssh user@host.dynamicip.net

Only the first (logging into user@host.local) currently works; if I ssh to the dynds address, no dice.

ssh user@host.dynamicip.net I get:

Permission denied (publickey,keyboard-interactive).

1) Obviously key-based auth isn't working 2) I type in the verified, correct password.

Both password and key-based auth work locally.

Anyone have any thoughts?

share|improve this question
    
Is your LAN connected to the internet via a NAT firewall/router? –  Steven Monday Nov 28 '10 at 4:16
add comment

2 Answers

up vote 2 down vote accepted

The fact that you see an authentication error rules out /etc/hosts.{allow,deny} firewall issue.

What remains is are you connecting to the right server? Just check that when you are trying to connect using the dyndns address, you see the TCP connection on the server. Check also the ssh logs (/var/log/secur*/var/log/auth*)

share|improve this answer
    
@Mercea, I believe you've got it. I just moved a bunch of hardware around, so I bet the redirection is now going to my laptop, which is also running ssh. I feel very sheepish. I'll let you know for sure when I'm back home and can confirm. –  clearf Nov 28 '10 at 9:59
1  
So, here's what's going on. @Mercea, you were right on target. I'm sitting behind my firewall, which is port forwarding. However, I'm at a hotel right now, and I'm being "double natted" as at were, or at least firewalled, so my ssh request was actually going to a separate machine, as verified with netstat. Thank! –  clearf Nov 28 '10 at 15:10
    
I am glad that I could help. –  Mircea Vutcovici Nov 29 '10 at 1:55
add comment

Check your /etc/hosts.allow file. Easiest thing to eliminate that as source of issues is add the line sshd : ALL : allow to that file (or replace any existing line that begins with 'sshd' with that).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.