Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Windows 2008 R2 from a USB stick and it hangs during the expanding files, generally in 23% if I install Standard and 16% if it's Enterprise.

I checkdisk the USB it's fine, tried 3 times to ensure that files are not corrupted. Did memory check.

Even more interesting I tried to install Windows 7 and very same behaviour happens.

Any ideas?

share|improve this question
Did you change the memory? Did you try a different USB stick? Is the hard drive ok? – user3914 Nov 28 '10 at 7:11
HHD was working fine a in a different system, don't have another USB Stick but it works perfectly fine and installed many systems with it before, I had 4GB of RAM uninstalled 3 of them just to decrease the risk, don't have any other to change. – Dave Rock Nov 28 '10 at 7:27

As expected it was HDD, even though checkdisk and everything else looked fine when I changed the HDD it worked just fine.

share|improve this answer
This is one of those occasions where I use the "format" option rather than "quick format" in setup. I've discovered drives that I thought were ok that ended up being faulty. Better to find out right at the start before relying on it for a server (or a workstation). – MikeAWood Apr 15 '12 at 18:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.