Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have written an extension to the FTP server on Windows 7.

When I try to log in, I get a 503 error. The logs don't show any issues.

I've tried to monitor the file with filemon, but nothing shows up there either.

It's probably a security issue, but I can't find it.

All of the documentation I've ready says Windows 7 and Server 2008 are possible uses of such an extension. Unfortunately the step-by-step guides are all for Server 2008.

-- Edit --
How do I install my extension, so that it will be used when a user logs in to my FTP server?

Does anyone have a pointer to any information regarding installing this on Windows 7?

-- Edit 2 --
I am trying to use the IIS server and the integrated FTP 7.5 server on a Windows 7 machine. I know this can be done on Server 2008, but am trying to get this working on W7 for customers without Server 2008.

-- Edit 3 --
Since this got migrated from StackOverflow, I'm hoping there's some Windows 7 love over here!

share|improve this question
1  
Do you mean an extension for IIS? –  Leo Davidson Nov 29 '10 at 12:59
add comment

migrated from stackoverflow.com Nov 30 '10 at 1:08

This question came from our site for professional and enthusiast programmers.

4 Answers

Have you tried to setup User Access Control to Never Notify. Please check following URL that would help you with the same:

http://learn.iis.net/page.aspx/632/how-to-use-managed-code-c-to-create-an-ftp-provider-that-sends-an-email-when-files-are-uploaded/

share|improve this answer
    
I've been using learn.iis.net/page.aspx/598/… It works on server 2008, but not Windows 7. –  Brad Bruce Dec 8 '10 at 11:46
add comment

503 - Service unavailable or Bad sequence of commands. This error code is specific to IIS 6.0. You can check through telnet if the FTP service is working fine

telnet ipaddress 20

Also check your username and password are correct.

share|improve this answer
    
My routine extension currently returns true, without checking the ID or password. This is the error I get. 530-User cannot log in. Win32 error: Unspecified error Error details: An error occured during the authentication process. 530 End –  Brad Bruce Dec 10 '10 at 11:48
    
that should be telnet ipaddress 21 –  JamesK Dec 10 '10 at 16:52
add comment

How have you registered them so far? It's your %windir%\system32\inetsrv\config\administration.config file where the registration should occur. Search that for 'ftp' and you'll see how the other extensions are registered.

Edit: Since it's a 503 error and if your module inherits from the standard FTP auth, which I assume it does, then make sure that your FTP authentication is set correctly (i.e. basic auth) and your authorization is set correctly too. As a test only, open up authorization to allow all users. There was a bug a while back where certain IIS Manager users wouldn't work with authorization rules, so you may be running into something like that. Test with it wide open to get in, then lock it down afterward.

Use process monitor from www.sysinternals.com to track down access denied issues on disk.

share|improve this answer
    
It's registered there, just like the others. –  Brad Bruce Dec 10 '10 at 11:43
    
It's likely that it's registered correctly then. It could be standard FTP authentication and authorization. I edited my post to mention that. –  Scott Forsyth - MVP Dec 10 '10 at 16:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.