Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We use "Copy file.prn to \tsclient\com1" to print from a TS session to a locally attached serial printer.

This works fine from Windows XP, but when trying it from a Windows 7 client computer, we get an "Access is denied" error message.

And yes, the check box of COM port is selected on the Local Resources tab of the Remote Desktop Connection client.

Any pointers? Has anyone even managed to do this successfully?

share|improve this question
    
Please clarify: you use this scheme to print from a TS session to a locally attached printer? –  Posipiet Nov 30 '10 at 10:02
    
@Posipiet: I edited the question to answer your question. –  Ola Eldøy Nov 30 '10 at 10:25
    
I have a same problem with no solution and Microsoft didn't helped me. My COM port is always mapped to server, but it works only when mstsc.exe is running as administrator with high privileges. Did you get some solution other than make user a local administrator? –  user125993 Jun 26 '12 at 8:00

1 Answer 1

up vote 1 down vote accepted

Several potential solutions come to mind:

One: Win7 UAC may be the culprit with COM access. Find a way to give the user access to Com. To diagnose this, first try to copy a local file (from computer console, not from tssession). Then try the same as an admin. Perhaps admin the user for a short period of time.

If this is the case, it might be fixed with a GPO in the vicinity of "Computer Configuration\Policies\Administrative Templates\System\". You want to allow users to use com and change its settings.

Two: You may share the printer on the tsclient, and use it on the server. To hide the local printer from network view, share it with "show in directory" off, and the share name ending in "$". Say "hiddenprint$" - shares ending with $ dont show in the explorer.

Then "copy file.prn \tsclient\hiddenprint$".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.