Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running CentOS on a storage server that has to do file sharing for with Windows machines. SMB version is smbd version 3.5.5-68.fc13

I'm getting a lot of error messages in /var/log/messages regarding failed attempts to connect to a CUPS server. They look like this:

Nov 30 18:49:34 big03 smbd[9927]: [2010/11/30 18:49:34.850620,  0] printing/print_cups.c:108(cups_connect)
Nov 30 18:49:34 big03 smbd[9927]:   Unable to connect to CUPS server localhost:631 - Connection refused

I understand that the issue is generated by the fact that SMB comes with printer sharing support, but I'm really not interested in that. I just want to disable the feature to get rid of the messages.

Any idea how I can do that?

share|improve this question

3 Answers 3

up vote 12 down vote accepted

Commenting out the printers section actually does nothing, add this to your smb.conf:

load printers = no
printing = bsd
printcap name = /dev/null
disable spoolss = yes

(spoolss is not a typo)

share|improve this answer

Just remove or comment out the [printers] section from the smb.conf file. Here is an example how it could look when commented out:

;[printers]
;   path = /var/spool/samba
;   guest ok = yes
;   printable = yes

(A semicolon at the beginning of a line marks as a comment line).

share|improve this answer
    
wrong answer, it does not solve the question the op asked –  dwery Nov 28 '12 at 10:58
    
@dwery: did you test this? –  Kurt Pfeifle Dec 1 '12 at 15:58
    
@dwery: Just because one answer is a tad bit different from mine and is the 'accepted' one doesn't mean that my answer is wrong or doesn't also solve the problem. For the record: the accepted answer will also work, yes. And at the time I did even test my own answer (albeit with a different, but similar version of Samba). -- Did you test any of the two?! –  Kurt Pfeifle Dec 1 '12 at 16:01
1  
yes, I tested both before commenting. Yours did not disable printing support, at least on my samba server, while the other one did. smbd was still trying to use cups. –  dwery Feb 8 '13 at 1:36

Becareful about missing network interfaces referenced in Samba config file! Put: log level = 2 into cinfig file, restart Samba and check log entries. Worked for me ;-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.