Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

when i "netstat -an | grep LISTEN"

i have line:

tcp6       0      0 127.0.0.1:24030         :::*                    LISTEN     

i want it to be

tcp6       0      0 ::24030         :::*                    LISTEN     

in other words i want to have this port opened to whole LAN, now it is only accesible from local machine

how can i do it?

im on ubuntu 10.04

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Your jetty server is listening only on localhost. Change jetty config to listen on all interfaces. Then set rule in your firewall to accept requests on port 24030 for example sudo ufw allow 24030

share|improve this answer
    
yup, there is security part of config file, you can just remove it (of course beware of consequences) –  Marek Dec 1 '10 at 11:58

And if you need jetty to be visible/accessable from local network in a Eclipse (web, spring, google app engine) development, you just add --address=0.0.0.0 or -a 0.0.0.0 in your Debug configuration/Arguments/Program arguments. Default jetty setting is localhost and as such is visible just on server.
Thanks to Casual Coder for pointing me in the right direction!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.