Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Here is what happens. Server is powered down but can get access to the IMPI card. Within the IPMI utility I tell the server to power up. When I tell the server to power up the network connection is temporarily lost for 30-60 seconds. Although the connection comes back that first 30-60 seconds is when I need to get into the server bios over the IMPI KVM. But because no connection I cannot get into the bios and the O/S boots up.

Now when installing the server and setting up at a number of areas I've never had this issue, but since it's moved into a dedicated datacenter this problem has come about. The way this wasn't an issue until in a datacenter makes me believe it's the way the switch is configured in the datacenter that's causing the temporary loss when the server powers up.

The server is connected into a Cisco Metro Ethernet 3750 Series. Anyone had this issue before and is there a configuration that needs to be set on the network to stop this from happening?

Thanks

Scott

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Sounds like the switch port is configured for the standard Spanning Tree Blocking\Listening\Learning process followed by Etherchannel and Trunk detection. In total they keep the port offline for at least 30 seconds after it has come online from a physical perspective.

If you are 100% certain that the port in question will only ever be used for connecting a server and trunking\etherchannel aren't needed the port can be changed to Access Mode and STP changed to PortFast. That should save at least 30 seconds off the time you are seeing and I'd expect it to remove all of the delays.

If this is what is happening then it will stll go offline briefly as that appears to be a feature of your systems IPMI port but hopefully that wont be too disruptive.

share|improve this answer
1  
+1. My first thought was "enable portfast". –  Jed Daniels Dec 2 '10 at 16:09
    
The datacenter network guy enabled Portfast on the port has fixed the issue. Thanks for the answer –  Brady Dec 2 '10 at 16:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.