Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to increase the Response timeout for IIS7-FastCGI-PHP based application using web.config file on my shared hosting account. I want to do this because, if my script takes more than 30~40 seconds to execute, IIS7 is returning 500 Internal server error. Any script that takes more than 30~40 seconds, it returns 500 internal server error. I tried with ASP script also, but the same result.

I have access to Web.config file only, so i tried below methods without any positive results. I added

<system.web>
<httpRuntime executionTimeout="120">
</system.web>

The above directive is for IIS6 version i think, so it did not make any effect. Is there any alternative for the above directive in IIS7?, i did not find any.

Then i tried with below tags and related child like cgi and fastCgi, but no effects.

<system.webServer>
</system.webServer>

Any solutions or suggestions on how to increase the Timeout?, thanks in advance.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

FastCGI and PHP both have their own timeout settings that also affect this. See this blog post on IIS.Net for details:

http://blogs.iis.net/donraman/archive/2010/02/08/troubleshoot-my-php-script-is-timing-out.aspx

The problem you are going to have is that some of these things (like the FastCGI configuration section) are done (exclusively if I remember correctly) at the applicationHost.config file level, not in the web.config file. You would need to talk to your hosting provider to increase the timeouts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.