Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi I have installed curl and curl-devel, but i still can't get curl to work with php. My php config line:

'./configure' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-gd' '--with-mysql' '--with-zlib' '--enable-mbstring' '--with-pdo-mysql' '--prefix=/php-5.3.3' '--with-config-file-path=/php-5.3.3' '--with-mysqli=/usr/bin/mysql_config'

Installed curl packages:

curl.i386 7.16.4-1.fc7 installed 
curl-devel.i386 7.16.4-1.fc7 installed

After installing curl #yum curl it should auto enable it for php, but curl still not available in php.

Thanks in advance.

share|improve this question
    
in your php.ini file is extension=php_curl.dll commented out? –  Kyle Hudson Dec 2 '10 at 14:54
    
yes, its commented out. –  taras Dec 2 '10 at 14:58
    
Are you really running Fedora 7? Please, please upgrade. Fedora 7 reached end-of-life on 2008-06-13 and you are living on a security time-bomb waiting to explode. (That's not Fedora-specific, but true for any unsupported OS.) If you need a longer lifecycle, please consider CentOS or Ubuntu LTS. –  mattdm Dec 2 '10 at 15:03
    
can i reconfigure my php config line with --with--curl ? or need to compile php again ? –  taras Dec 2 '10 at 15:04
    
Yes :) thanks for your advice, i will work on it :) –  taras Dec 2 '10 at 15:06
add comment

1 Answer

up vote 1 down vote accepted

You need to add --with-curl to php's configure

Or try this since you already compiled if you still have the source.. not sure

cd php-5.3.3/ext/curl
phpize
./configure
make
make install

Then enable the extension in php.ini. It will be a .so file not a .dll

share|improve this answer
    
Can i add --with-curl to the config manually ? or need to use phpize ? –  taras Dec 2 '10 at 15:16
    
I guess i got the source, i tried this: [root@wow bin]# phpize Cannot find config.m4. Make sure that you run '/usr/local/bin/phpize' in the top level source directory of the module –  taras Dec 2 '10 at 15:17
    
Thanks to all, problem solved, i recompiled php and everything is fine now! –  taras Dec 2 '10 at 16:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.